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1
はじめに
PSoC 1 は、単一のチップ上にカスタム アナログとデジタル ペリフェラル機能、メモリおよび M8C マイクロコントローラーを集
積した、真のプログラマブルな組み込みシステムオンチップです。
これは、マイクロコントローラー (MCU) と外部アナログ／デジタル ペリフェラルの組み合わせを使用するアナログ／デジタル
混在の組み込みシステムとは異なります。通常、このシステム タイプは MCU に加えて、オペアンプ、ADC、デジタル ASIC など
多くの集積回路を必要とします。
PSoC 1 は、MCU と外部 IC の組み合わせの代わりに低コストのソリューションを提供しています。システム全体のコストを削減
する以外、プログラマブル アナログとデジタル サブシステムにより、設計の高い柔軟性、インフィールド チューニングおよび短い
製品化までの時間が可能になります。
PSoC 1 のシステム リソースは、全く異なる機能を実行するよう実行中にダイナミックにリコンフィギュレーションすることが
できます。ダイナミックなリコンフィギュレーションは、リソースが設計に消費された場合にも可能です。これにより、PSoC 1 の
システム リソースを再利用し、集積能力を最大限に発揮させることができます。
PSoC 1 の CapSense®という静電容量タッチ センシング機能は、比類のない信号対ノイズ比 (SNR) 、クラス最高の耐水性、
および多種多様なセンサー タイプ (ボタン、スライダー、トラック パッド、近接センサーなど) を提供しています。
本アプリケーション ノートは、PSoC 1 のアーキテクチャおよび開発ツールを研究するのに役立ち、PSoC 1 の開発ツール
である PSoC Designer™を使用して初めてのプロジェクトを作成する方法を案内します。本書はまた、PSoC 1 を迅速に深く
理解できるように更なるリソースへのアクセスを提供します。
PSoC 1 に加えて、サイプレスの PSoC ポートフォリオは PSoC 3、PSoC 4 および PSoC 5LP デバイスを含んでいます。
PSoC デバイスによってシステム アーキテクチャおよびペリフェラルが異なります。詳細については、「Cypress Platform
PSoC Solutions Roadmap」を参照してください。
2
概要
サイプレスは、ユーザーが設計に適切な PSoC デバイスを選択し、デバイスを設計に迅速で効果的に統合するのに役立つ豊
富な情報を www.cypress.com に掲載しています。リソースの総合リストについては、知識ベース記事「How to Design with
PSoC® 1, PowerPSoC®, and PLC – KBA88292」を参照してください。以下は PSoC 1 のリソースの要約です。




概要: PSoC ポートフォリオ、PSoC ロードマップ
製品セレクタ: PSoC 1、PSoC 3、PSoC 4、PSoC 5LP
さらに、PSoC Designer にはデバイス選択ツールが含まれています。
アプリケーション ノート: サイプレスは、基本レベルから上級レベルまでの様々なトピックに触れる大量の PSoC アプリケーション
ノートを提供します。以下は PSoC 1 入門用の推奨アプリケーション ノートです。





AN75320 - Getting Started with PSoC® 1
AN2094 - PSoC® 1 - Getting Started with GPIO
AN74170 - PSoC® 1 Analog Structure and Configuration with PSoC Designer™
AN2041 - Understanding PSoC® 1 Switched Capacitor Analog Blocks
AN2219 - PSoC® 1 Selecting Analog Ground and Reference
注: CY8C29X66 デバイスに関するアプリケーション ノートについては、ここをクリックしてください。
 開発キット:

CY3210-PSoCEval1 は、CY8C25/26xxx デバイスを除いて、車載用デバイスを含むすべての PSoC 1 アナログ／
デジタル混在信号アレイ ファミリに対応しています。このキットには、LCD モジュールやポテンショメーター、LED、
ブレッドボードが含まれています。
 CY3214-PSoCEvalUSB は、CY8C24x94 PSoC デバイスの開発用基板を備えています。この基板の特殊な特長
には、USB および CapSense 開発とデバッグ サポートが含まれています。
注: CY8C29X66 デバイスに関する開発キットについては、ここをクリックしてください。
MiniProg1 および MiniProg3 デバイスは、フラッシュのプログラミングとデバッグ用のインターフェースを提供します。
www.cypress.com
文書番号: 001-79363 Rev. *D
2
================
®
PSoC 1 入門
________________________________________________________________________________________________________________
2.1
PSoC Designer
PSoC Designer は無料の Windows ベースの統合設計環境 (IDE) です。アプリケーション開発は、特性化済みのアナログと
デジタル ペリフェラルのライブラリを使用してドラッグ アンド ドロップの設計環境で行われます。また、API ライブラリ上の動的
生成が行えるコードを活用して、設計をカスタマイズすることも可能です。図 1 は PSoC Designer ウィンドウを示します。
注: これは、デフォルト画面ではありません。
1.
グローバル リソース: すべてのデバイス ハードウェアの設定
2.
パラメーター: 選択しているユーザー モジュールのパラメーター
3.
ピン配置: デバイスのピンに関する情報
4.
チップ レベル エディター: 選択したチップで使用可能なリソースの図
5.
データシート: 選択しているユーザー モジュールのデータシート
6.
ユーザー モジュール: 選択したデバイスのすべての使用可能なユーザー モジュール
7.
デバイス リソース メーター: 現時点のプロジェクト コンフィギュレーション用のデバイス リソースの使用率
8.
ワークスペース: プロジェクトに関するファイルを表示するツリー レベル図
9.
出力: プロジェクト ビルドおよびデバッグ処理からの出力
注: PSoC Designer の詳細情報については、 PSoC Designer IDE の Help > Documentation をアクセスし、
「 Designer Specific Documents 」 フ ォ ル ダ を 開 い て 「 IDE User Guide.pdf 」 ド キ ュ メ ン ト を ご 覧 く だ さ い 。
図 1．PSoC Designer のレイアウト
www.cypress.com
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2.2
サンプル コード
以下のウェブページには PSoC Designer ベースのサンプル コードがリストアップされています。これらのサンプル コードは、
空のページの代わりに完了した設計で始まり設計時間を短縮させることができ、PSoC Designer ユーザー モジュールが
様々な用途にどのように利用できるかを示します。
http://www.cypress.com/documentation/code-examples/psoc-1-code-examples
PSoC Designer に統合されているサンプル コードへアクセスするには、図 2 に示すように Start Page > Design Catalog >
Launch Example Browser を順に選択してください。
図 2. PSoC Designer 内のサンプル コード
図 3 に示す Example Projects Browser には以下のオプションがあります。




プロジェクトをフィルタリングするためのキーワード検索

さらに、選択に応じて新規プロジェクト (また、必要な場合は新規ワークスペース) を作成することができます。完成した
基本的な設計で始まり設計時間を短縮させます。その設計をアプリケーションに適用することができます。
カテゴリ ベースのプロジェクト リスト
選択したプロジェクトのデータシートをレビューします (Description タブで)
選択したプロジェクトのサンプル コードをレビューします。このウィンドウからコードをプロジェクトにコピー アンド ペーストして
コード開発時間を短縮させることができます。
www.cypress.com
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図 3. サンプル プロジェクトおよびサンプル コード
2.3
PSoC Designer Help
PSoC Designer ホームページへアクセスして PSoC Designer の最新版をダウンロードしてください。PSoC Designer を起動
して次の項目に移動します。
2.4

IDE ユーザー ガイド: Help > Documentation > Designer Specific Documents > IDE User Guide.pdf を選択
します。このガイドは PSoC Creator プロジェクトを開発するための基礎知識を提供します。

シンプルなユーザー モジュールのサンプル コード: Start Page > Design Catalog > Launch Example Browser
を選択します。これらのサンプル コードは PSoC Designer ユーザー モジュールのコンフィギュレーションおよび使用方
法をデモします。

テクニカル リファレンス マニュアル: Help > Documentation > Technical Reference Manuals を選択します。このガイド
は PSoC 1 デバイスのシステム機能を一覧にして説明します。

ユーザー モジュール データシート: ユーザー モジュールを右クリックして「Datasheet」を選択します。このデータシート
は選択されたユーザー モジュールのパラメーターおよび API を説明します。

デバイス データシート: Help > Documentation > Device Datasheets を選択して特定の PSoC 1 デバイスのデータ
シートへアクセスします。

Imagecraft コンパイラ ガイド: Help > Documentation > Compiler and Programming Documents > C Language
Compiler User Guide.pdf を選択します。このガイドは Imagecraft コンパイラ固有の命令と関数について説明します。
テクニカル サポート
ご質問は、弊社のテクニカル サポート チーム対応いたします。サイプレスのテクニカル サポート ページにアクセスし、
お問い合わせ内容をケースとして作成し送信してください。
米国のお客様は、弊社フリーダイヤル (+1-800-541-4736 ext.8) までお電話いただければ、弊社のテクニカル サポート チームが
ご対応いたします。
www.cypress.com
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早急な対応が求められる場合には、下記の方法をご利用ください。


3
セルフ ヘルプ
所在地の販売代理店
PSoC 1 ファミリの比較
PSoC 1 には 13 デバイス ファミリがあります。表 1 は、これらのデバイス ファミリで対応されている機能を示します。
表 1. PSoC 1 デバイス セレクタの概要表
デバイス ファミリ
機能
29x66
28xxx
27x43
24x94
24x93
24x33
24x23A
23x33
22x45
21x45
21x34
21x23
32K
16K
16K
16K
32K
8K
4K
8K
16K
8K
8K
4K
SRAM (KB)
2K
1K
256B
512B
2K
256B
256B
256B
1K
512B
512B
256B
ADC 1
14
ビット
(DS)
4x14
ビット
(DS)
11
ビット
(DS)
14
ビット
(DS)
10
ビット
(INC)
11
ビット
(DS)
11
ビット
(DS)
11
ビット
(DS)
8
ビット
(SS)
8
ビット
(SS)
10
ビット
(SS)
10
ビット
(SS)
-
10
ビット
(150
Ksps)
-
-
-
8
ビット
(300
Ksps)
-
8
ビット
(300
Ksps)
10
ビット
(150
Ksps)
10
ビット
(150
Ksps)
-
-
4
4
4
2
2
2
2
2
4
4
2
2
4
4
4
2
-
2
2
2
-
-
-
-
4
4
4
2
-
2
2
2
-
-
-
-
8
6
4
2
3
(タイマー)
2
2
2
4
2
2
2
UART/SPI
4
3
2
1
1 SPI
1
1
1
2
1
1
1
I2C
1
2
1
1
1
(スレーブ)
1
1
1
1
1
1
1
CapSense
ボタン
-
43
-
49
-
-
-
-
37
23
23
-
GPIO
64
44
44
50
36
26
24
26
38
24
24
16
USB
-
-
-
FS 2.0
FS 2.0
-
-
-
-
-
-
-
ECO
Y
Y
Y
N
Y
Y
Y
Y
Y
Y
N
N
SMP
Y
Y
Y
N
N
N
Y
N
Y
Y
Y
Y
MAC
2
2
1
2
0
1
1
1
1
1
0
0
フラッシュ
(KB)
(DS/SS)
ADC 2
(SAR)
コンパレータ
DAC
(8 ビット)
PGA
(x48 ゲイン)
TCPWM
(16 ビット)
FS = フル スピード、SMP = スイッチ モード ポンプ、ECO = 外部水晶振動子、MAC = 積和演算器、INC = インクリメンタル、DS = デュアル スロープ、SS = シングル スロープ、PGA = プログラマブル ゲ
イン アンプ、TCPWM = タイマー カウンター パルス幅変調器、UART = ユニバーサル非同期レシーバー トランスミッター、SPI = シリアル ペリフェラル インターフェース、I2C = インター インテグレーテッド
サーキット
www.cypress.com
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4
PSoC 1 の機能セット
PSoC 1 は図 4 に示すように、CPU コア、デジタル サブシステム、アナログ サブシステム、メモリ サブシステム、システム
リソースを含む幅広い能力と機能を備えています。次の節は各機能について簡単に説明します。詳細については、PSoC 1
ファミリのデバイス データシート、テクニカル リファレンス マニュアル (TRM) および「PSoC 1 学習資料」にリストアップされた
アプリケーション ノートを参照してください。
図 4. PSoC 1 アーキテクチャ (CY8C29466)
Port 7
Port 6
Port 5
Port 4
Port 3
Port 2
Port 1
Port 0
Analog
Drivers
SYSTEM BUS
Global Digital Interconnect
Global Analog Interconnect
PSoC CORE
Supervisory ROM (SROM)
SRAM
Flash Nonvolatile Memory
CPU Core (M8C)
Interrupt
Controller
24 MHz Internal Main
Oscillator (IMO)
Internal Low Speed
Oscillator (ILO)
Sleep and
Watchdog
Phase Locked
Loop (PLL)
32 KHz Crystal
Oscillator (ECO)
Multiple Clock Sources
DIGITAL SYSTEM
ANALOG SYSTEM
Digital PSoC Block Array
Analog
Ref
Analog PSoC
Block Array
DBB00
DBB01
DCB02
DCB03
DBB10
DBB11
DCB12
DCB13
CT
CT
CT
CT
DBB20
DBB21
DCB22
DCB23
SC
SC
SC
SC
SC
SC
SC
SC
DBB30
DBB31
DCB32
DCB33
1 to 4 Digital Rows
Analog
Input
Muxing
1 to 4 Analog Columns
SYSTEM BUS
Digital
Clocks
Multiply
Accumulate
(MACs)
POR and LVD
Decimators
I2C
System Resets
Switch
Mode
Pump
Internal
Voltage
Reference
USB
IO Analog
Multiplexer
SYSTEM RESOURCES
図 4 は CY8C29466 デバイスで対応されている機能を示します。これらの機能のサブセットは他のデバイスで使用可能です。
表 1 を参照してください。
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4.1
M8C プロセッサおよびメモリ
PSoC 1 は、ハーバード アーキテクチャの 8 ビット RISC CPU である M8C プロセッサを内蔵しています。これは 24MHz
の最大周波数で動作可能で、4MIPS の性能を実現します。M8C には 37 の命令があります。表 1 に示すように、PSoC 1
デバイスは最大 2KB の SRAM と 32KB のフラッシュ メモリを内蔵します。詳細については、PSoC 1 テクニカル リファレンス
マニュアルを参照してください。
4.2
プログラマブル デジタル サブシステム
PSoC のデジタル サブシステムは、そのプログラマビリティと配線システムによりユニークなものとなっています。表 1 は、
各種の PSoC 1 製品および各デバイスで使用可能なデジタル リソースを一覧にします。PSoC 1 内のデジタル ブロックは
デジタル基本ブロック (DBB) とデジタル通信ブロック (DCB) に分かれています。DBB 数と DCB 数は常に等しいです。
4.2.1
デジタル基本ブロック (DBB)
DBB は、タイマーやカウンター、PWM などとして機能させるようにプログラムできる基本的なコンフィギュレーション可能な
デジタル リソースです。各 DBB には 8 ビット リソースを割り当てられます。16 ビット、24 ビット、または 32 ビット デジタル リソース
を構築するにはそれぞれ 2 個、3 個、または 4 個の DBB が必要です。
4.2.2
デジタル通信ブロック (DCB)
DCB には、基本的なデジタル リソース (タイマーやカウンター、PWM など) を割り当てるだけでなく、SPI や UART などの
通信リソースを割り当てることもできます。DBB コンポーネントを DCB に配置することは可能ですが、DCB リソースを DBB に
配置することはできません。
4.3
プログラマブル アナログ サブシステム
PSoC 1 独自のアナログ サブシステムは、列に配置されたアナログ ブロックで構成されています。これらのアナログ ブロックは
連続時間 (CT) ブロックとスイッチト キャパシタ (SC) ブロックに分かれています。
4.3.1
連続時間 (CT) ブロック
PSoC 内の CT ブロックは、コンパレーターまたはプログラマブル ゲイン アンプ (PGA) としてコンフィギュレーションできる
プログラマブル アナログ ブロックです。CT ブロックは低ノイズ オペアンプと低オフセット オペアンプを中心に構築されています。
CT ブロックには多くのアナログ マルチプレクサがあり、高いコンフィギュアビリティを実現します。CT ブロックの構造と構成の
詳細については、PSoC 1 テクニカル リファレンス マニュアルの第 22 章を参照してください。
4.3.2
スイッチト キャパシタ (SC) ブロック
CT ブロックと同様に、SC ブロックはアナログ マルチプレクサに囲まれた低ノイズ オペアンプと低オフセット オペアンプを中心に
構築されています。これらのブロックは、オペアンプとマルチプレクサの周囲のキャパシタとスイッチのグループによりユニークな
ものとなっています。CT ブロックとは異なり、SC ブロックに抵抗アレイはありません。SC ブロックのアーキテクチャの詳細に
ついては、PSoC 1 テクニカル リファレンス マニュアルの第 23 章または「AN2041 – Understanding PSoC 1 Switch
Capacitor Analog Blocks」を参照してください。
4.4
システム全般リソース
4.4.1
クロッキング システム
PSoC は、複数のクロック ソースを持った高度なクロック システムを搭載しており、その中の多くはプログラム可能です。主要
のクロック ソースは、内蔵の 24MHz 内部主振動子 (IMO) または 24MHz 以下の外部クロック ソースから派生できます。
さらに、32kHz 振動子回路または内部低速振動子 (ILO) を低速振動子に使用することができます。PSoC 1 で使用可能な
クロックの詳細については、「AN32200 - PSoC® 1 - Clocks and Global Resources」を参照してください。
4.4.2
スイッチ モード ポンプ (SMP)
スイッチ モード ポンプ (SMP) は PSoC でサポートされている DC/DC ブースト回路であり、デバイスが単一の 1.5V バッテリで
動作できるようにします。PSoC には、ブースト回路の実行用に内蔵 FET および独立した PWM ハードウェアがあります。
ブースト回路の構成要素は外部バッテリ、インダクタ、ダイオード、コンデンサ各 1 個のみです。詳細については、PSoC 1
テクニカル リファレンス マニュアルの第 30 章を参照してください。
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4.4.3
積 和 演 算 器 ( M AC )
積和演算器 (MAC) は符号付数字の 8 ビット乗算器および総和用 32 ビット加算器を提供しています。MAC は演算の実行や
デジタル フィルターの実装に非常に便利です。デバイスの特定のレジスタに読み書きすることで MAC を使用できます。
乗算の後、値をレジスタから読み出すかアキュムレータに保存できます。クリア レジスタ (MACx_CL1 と MACx_CL2) に書き込む
ことでアキュムレータをクリアし、0 の値にリセットすることができます。詳細については、PSoC 1 テクニカル リファレンス
マニュアルの第 26 章を参照してください。
4.4.4
電圧リファレンス
PSoC 1 には電圧リファレンス向けに多くのオプションが用意されています。次は 3 つの主な用語です。
1.
AGND
2.
RefHi
3.
RefLo
デバイスのアナログ信号はアナログ グランド (AGND) にバイアスされています。AGND の電圧位置は開発者によって幅広い
オプションから選択されます。AGND より高いアナログ信号は正電圧、それ未満は負電圧とされます。RefHi と RefLo は
アナログ システムの上限と下限を意味します。詳細については、AN2219 - PSoC® 1 Selecting Analog Ground and
Reference を参照してください。
4.4.5
専用 I2C ハードウェア
I2C 通信ブロックは、PSoC デバイスを 2 線式 I2C シリアル通信バスとインターフェースするよう設計されたシリアル-パラレル
プロセッサです。M8C マイクロコントローラーの過剰な介入とオーバーヘッドをなくすために、このブロックは I 2 C 固有の
ステータス検出とフレーミング ビット生成のサポートを提供します。
以下は PSoC I2C ハードウェア コントローラーの主な特長と機能です。





業界標準の Philips® I2C バス互換インターフェース
マスターおよびスレーブ動作、マルチマスター可能
2 本のピン (SDA と SCL) のみで I2C バスとのインターフェースを実現
100/400kbps の標準データ転送速度；50kbps にも対応
7 ビット アドレッシング モード；10 ビット アドレッシングにも対応
2
I C の使用の詳細情報は、「AN50987: Getting Started with I2C in PSoC 1」を参照してください。
4.5
GPIO システム
GPIO システムは CPU やペリフェラルと外部間のインターフェースを提供します。各 GPIO は、デジタル I/O として使用される
と、ピン当たり 10mA の吐き出し電流、25mA の吸い込み電流が可能です。デバイスは片側 100mA、合計 200mA を吸い
込めます。したがって、任意のポートの偶数番号ピンは合計 100mA、奇数番号ピンはもう 100mA の電流に対応できます。
デバイスは片側 40mA、合計 80mA を吐き出せます。詳細については、PSoC 1 テクニカル リファレンス マニュアルの第 6 章
および「AN2094 - PSoC® 1 - Getting Started with GPIO」を参照してください。
4.6
CapSense
PSoC 1 デバイスには、CapSense として知られた静電容量タッチ センシングに対応しているデバイスがあります。静電容量
タッチ センサーは、人体の静電容量を使ってセンサー上またはセンサー近く (近接) の指の存在を検出するユーザー インタ
ーフェースのデバイスです。静電容量センサーは審美的に優れており、使い易く、長寿命を持っています。CapSense により、
高価で信頼性の低いメカニカル ボタンを、単にプリント基板上の銅配線である静電容量ボタンに置き換えることができます。
CapSense はボタンやスライダー、トラックパッド、近接センサーなど幅広いセンサーに対応しています。CapSense に対応
している PSoC 1 の一覧は、表 1 を参照してください。詳細については、「AN64846 - Getting Started with CapSense」を参照
してください。
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4.7
ダイナミックなリコンフィギュアビリティ
PSoC 1 では、最終製品の詳細が分かっていなくてもプロジェクトの設計を開始して、必要に応じてリソースを追加することが
できます。デジタルまたはアナログ リソースが利用可能である限り、調整、適用、拡張が可能です。リソースが消費されて
しまった設計でも、別の機能の実行するために実行中に PSoC をダイナミックにリコンフィギュレーションすることができます。
これにより、PSoC のシステム リソースを再利用し、集積能力を最大限に発揮させることができます。詳細については、
「AN2104 - PSoC®1 - Dynamic Reconfiguration With PSoC® Designer™」を参照してください。
5
開発ツール
サイプレスの PSoC 1 は、PSoC Designer ソフトウェア ツール、開発キットやプログラミング ハードウェア、デバッグ ハードウェア
を含むハードウェア ツールなどの品質の高い開発ツールでサポートされています。これらのツールにより、デバイスのコンフィ
ギュレーション、アプリケーション コードの開発、また組み込み設計のビルド、デバッグ、そして展開が可能です。
5.1
ソフトウェア: PSoC Designer IDE
サイプレスの PSoC Designer は、PSoC 1 デバイスのカスタマイズ、コンフィギュレーション、プログラミングに使用される統合
開発環境 (IDE) です。このツールは http://www.cypress.com/go/psocdesigner からダウンロードできます。
PSoC Designer は、アナログとデジタル ペリフェラルをコンフィギュレーションして PSoC アプリケーションを作成し、アプリ
ケーションコードを書き、本アプリケーション ノートで説明するその他の機能を実行することが可能な完全な開発環境を提供
します。さらにこのソフトウェアにより、PSoC ICE-Cube デバッグ プラットフォームを使用して PSoC デバイスをプログラムし、
プロジェクトをデバッグすることが可能です。
図 5 は、PSoC Designer のレイアウトおよび IDE の各部分の説明を示します。なお、これは PSoC Designer のデフォルト
レイアウトではありません。Designer を起動する時に以下に示すウィンドウが表示されない場合は、ツールバーの View
ドロップダウン メニューから追加できます。
図 5. PSoC Designer のレイアウト
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5.2
ハードウェア
サイプレスは設計の要件を満たすために PSoC 1 向けのハードウェア キットを提供しています。PSoC 1 デバイスを選択する
には、「PSoC 1 Kits」および「PSoC 1 Kit Selector Guide」を参照してください。以下の節は開発キット、プログラミング ハード
ウェアおよびデバッグ ハードウェアの一覧について紹介します。
5.2.1
開発キット
サイプレスは PSoC 1 設計を容易に試作する手助のためにいくつの開発キットを提供しています。表 2 は PSoC 1 の評価を
サポートするいくつかの開発キットを一覧にします。開発キット／基板の完全なリストについては、開発キットを参照してください。
表 2. PSoC 1 開発キット
開発キット
5.2.2
説明
CY3210PSOCEVAL1
CY3210 PSoC Eval1 キットにより、サイプレスの PSoC 1 プログラマブル システムオンチップの
設計手法とアーキテクチャの評価および実験が可能です。
CY8CKIT-001
CY8CKIT-001 PSoC 開発キットは、異なるソリューションの試作と評価を可能にする一般的な
開発プラットフォームを提供します。
プログラミング ハードウェア
サイプレス提供およびサードパーティのツールのいくつかのオプションから選択できます。サイプレスは 4 種のプログラミング
デバイスを提供しています: MiniProg1、MiniProg3、ICE-Cube、CY3207-ISSP。
MiniProg1
MiniProg1 は多くの PSoC 1 キットに同梱されている ISSP プログラマです。このプログラマは CY25/26xxx を除き、すべての
PSoC 1 デバイスに使用できます。MiniProg1 は PSoC 3 および PSoC 5 デバイスのプログラミングには使用できません。
MiniProg3
MiniProg3 は CY8CKIT-001 開発キットに同梱されている ISSP プログラマです。MiniProg3 には、PSoC 1、PSoC 3 および
PSoC 5 デバイス用のプログラマ、PSoC 3 および PSoC 5 アーキテクチャ用のデバッグ ツール、I2C シリアル接続のデバッグ
および PSoC デバイスとの通信用の USB-I2C ブリッジが一体化されています。
サードパーティのプログラマ
サードパーティのプログラマ ツールの一覧は、http://www.cypress.com/documentation/development-kitsboards/general-psocprogramming を参照してください。これらのツールは PSoC 1 デバイスのプログラミングをサポートするように設計およびテストされ、
サイプレスによって認定されました。
5.2.3
デバッグ ハードウェア
CY3215A-DK
CY3215A-DK In-Circuit Emulation Lite Development Kit にはインサーキット エミュレータ (ICE) が含まれています。ICECube は主に PSoC 1 デバイスのデバッグに使用しますが、ISSP を使用して PSoC 1 デバイスのプログラムもできます。
青色の CAT5 ケーブルやフレックス ケーブルを使ってデバッグ ポッドとインターフェースする代わりに、黄色の ISSP ケーブル
を使ってデバイスをプログラムすることができます。このため、ICE-Cube はデバッグとプロダクション環境に非常に便利です。
詳細は、「AN73212 – Debugging with PSoC 1」を参照してください。
6
PSoC 1 学習資料
本節は、PSoC 1 の入門および完全なアプリケーションの開発に役立つ PSoC 1 学習資料の一覧を提供します。データシート、
リファレンス マニュアル、ビデオ、アプリケーション ノートなど PSoC 1 開発者が利用できる多くのリソースが用意されています。
6.1
PSoC 1 データシート
全ての PSoC 1 デバイス ファミリの機能および電気的仕様をリストアップする PSoC 1 データシートについては、PSoC 1
データシートのページにアクセスしてください。
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6.2
PSoC 1 Designer の学習
PSoC Designer ホームページへアクセスして PSoC Designer の最新版をダウンロードしてください。
PSoC Designer を起動して次の項目に移動します。
PSoC Designer ユ ー ザ ー ガ イ ド : PSoC Designer ユ ー ザ ー ガ イ ド の ペ ー ジ へ ア ク セ ス し て く だ さ い 。
6.2.1
IDE ユーザー ガイド:
PSoC Designer を起動して、Help > Documentation > Designer Specific Documents > IDE User Guide を選択します。
このガイドは PSoC Designer プロジェクトを開発するための基礎知識を提供します。
6.2.2
サンプル プロジェクト
PSoC Designer を起動して、Design Catalog > Example projects を選択します。これらのサンプル プロジェクトは、
PSoC Designer のコンポーネントのコンフィギュレーションと使用方法をデモします。
6.2.3
PSoC Designer のトレーニング
これらのトレーニングは設計の手助けとなり、「Intro to PSoC Designer」、「Dynamic Reconfiguration」および「Debugging
with PSoC」の内容を演習します。
6.2.4
コンポーネント データシート:
PSoC Designer を起動して、Workspace Explorer を開きます。Chip タブで、コンポーネントを右クリックして Datasheet を
選択します。
6.3
アプリケーション ノート
アプリケーション ノートは、デバイスの特定の機能を理解し、PSoC 1 アプリケーションを設計する手助けをします。PSoC 1
のアプリケーション ノートの完全なリストについては、PSoC 1 アプリケーション ノートのページへアクセスしてください。
6.4
知識ベース記事
技術サポート関連のよく聞かれる質問と答えを蓄積したデータベースがあります。PSoC 1 の知識ベース記事の完全なリスト
については、知識ベース記事のページへアクセスしてください。
6.5
テクニカル リファレンス マニュアル (TRM)
TRM は PSoC 1 デバイスの内部アーキテクチャの詳細な説明を提供します。PSoC 1 の TRM の完全なリストについては、
PSoC 1 テクニカル リファレンス マニュアルのページへアクセスしてください。
6.6
デバイス エラッタ
これらの資料は、デバイス データシートまたはテクニカル リファレンス マニュアルから外れる仕様 (ある場合) を記載しています。
デバイスのエラッタ資料の一覧については、デバイス エラッタのページへアクセスしてください。
6.7
テクニカル サポート
お問い合わせまたはご質問は、弊社のテクニカル サポート チームが対応いたします。サイプレスのテクニカル サポートに
アクセスし、お問い合わせ内容をケースとして作成し送信してください。
米国のお客様は、弊社フリーダイヤル (+1-800-541-4736 ext.8) までお電話いただければ、弊社のテクニカル サポート チームが
ご対応いたします。
早急な対応が求められる場合には、下記の方法をご利用ください。


セルフ ヘルプ
所在地の販売代理店
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7
はじめての PSoC 1 設計
本節は、PSoC Designer を用いて PSoC 1 を使ったシンプルなデザインを設計して、それを PSoC デバイスにプログラムし、
また PSoC 1 デモ基板をコンフィギュレーションしてアプリケーションの結果を検証する、段階を追ったプロセスを説明します。
7.1
設計について
本設計では、2 つの GPIO で 2 つの PWM 出力 (1 つはハードウェア リソースを使用し、もう 1 つはソフトウェアを使用) を
生成するシンプルなプロジェクトを作成します。1 つの GPIO は固定速度で点滅する LED を示し、もう 1 つの GPIO はパルス
(ハートビート) LED を示します。本設計ではまた、ADC ユーザー モジュールを使用してアナログ電圧を測定します。
7.2
はじめての PSoC 1 設計の作成
7.2.1
プロジェクトの作成
まず、PSoC Designer でプロジェクトを作成します。ここで、デバイスを選択して、開発言語を C に設定します。この例では、
CY3210-PSoCEval1 キットに同梱されている CY8C29466-24PXI を使用します。
1.
図 6 に示すように、PSoC Designer で File > New Project を選択して AN75320 と名付けます。
図 6. PSoC Designer で新規プロジェクトを作成
2.
図 7 に示すように、Device Catalog をクリックしてデバイスを選択します。
図 7. 「Device Catalog」
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注: このプロジェクトを他のキットで開発する際は、以下の製品番号を使用してください。


CY3214-PSoCEvalUSB: CY8C24994-24LTXI
3.
「Create Project with CY8C29466-24PXI」をクリックして、OK をクリックします。
CY3271-PSoC First Touch: CY8C20634-12FDXI
プロジェクト ワークスペースが開き、Chip Editor と Workspace Explorer を表示します。Chip Editor は、選択したデバイスの
ブロック図を示します。Ctrl を押しながらクリックして Chip Editor ビューをズームインします。
7.2.2
ユーザー モジュールの選択
このステップでは、User Module Catalog から必要なコンポーネントを選択してそれらをコンフィギュレーションします。ユーザ
モジュールのウィンドウは図 8 に示すように、右下にあります。View > User Module Catalog を選択してそれを表示させます。
図 8. ユーザ モジュール カタログ ウィンドウ
このプロジェクトは次のユーザ モジュールを使用します。



ADC ユーザー モジュール 1 個
1.
ユーザ モジュールを配置するするには次のステップを行ってください：User Module Catalog 内で ADCs フォルダを
展開します。
2.
EzADC を右クリックして、Place を選択します。EzADC コンフィギュレーション ウィンドウが開きます。
3.
コンフィギュレーション ウィンドウ内で Double Stage Modulator を選択して、OK をクリックします。(このコンフィギュレーション
では、高い性能のために 2 個のスイッチト キャパシタを使用します。)
4.
PWMs フォルダの下で PWM8 を右クリックして、Place を選択します。
5.
配置プロセスを繰り返して 2 個の PWM8 ユーザー モジュールを設計に配置します。
6.
Misc Digital フォルダから LCD をクリックして、Place を選択します。
PWM8 ユーザー モジュール 2 個
LCD ユーザー モジュール 1 個
必要なユーザー モジュールの配置を完了した後、Designer ウィンドウは図 9 のようになります。また、配置したユーザー
モジュールは Workspace Explorer に表示されます。配置した各ユーザー モジュールは ComponentName_1 などのように
名付けられます。例えば、EzADC ユーザー モジュールは EzADC_1 としてリストアップされます。
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図 9. Chip Editor 内の EzADC と PWM ユーザー モジュールの配置 (デジタル ブロック)
図 10. Chip Editor 内の EzADC ユーザー モジュールの配置 (アナログ ブロック)
7.2.3
ユーザー モジュール パラメーターの設定
このステップでは、設計に配置したユーザー モジュールのパラメーターを設定します。
Workspace Explorer または Chip Editor からユーザー モジュールをクリックすると、選択したユーザー モジュールの
Parameters ウィンドウが左側に表示されます。このウィンドウでは、パラメーターを変更することができます。
設定または変更するパラメーターについては、以下の図を参照してください。
1.
EzADC_1 を選択して、そのパラメーターを表 3 に基づいて変更します。変更した後、ウィンドウは図 11 のようになります。
初期設定値から変更されるパラメーターは強調表示されています。
表 3. EzADC_1 ユーザー モジュールのパラメーター
パラメーター
値
説明
Name (名称)
EzADC_1
ユーザー モジュールに名称を付ける
DataFormat (データ形式)
Unsigned (符号なし)
入力は正の値のみであるため、出力を符号
なしデータに設定
Resolution (分解能)
14 Bit
EzADC の最大分解能を設定
(14 ビット)
0.007
サンプル レートは分解能に依存。EzADC
のユーザー モジュール データシートを参照
してください。
Input (入力)
AnalogColumn_Inpu
tMUX_0
ソースの入力アナログ電圧を受信するよう
アナログ入力データ バスを選択
Offset Compensation
Enable (有効)
相関 2 重サンプリングを有効にする
Sample Rate
(サンプル レート)
(オフセット補正)
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パラメーター
値
説明
Buffer Gain (バッファ ゲイン)
1.000
増幅しないように PGA ゲインを 1 に設定
Reference (リファレンス)
VSS
オフセット補正を行うために PGA のリファレ
ンス電圧を設定
AGND Output (AGND 出力)
Disable (無効)
AGND 出力を無効にする。このオプション
は、内部 AGND を外部ピンに出して両極性
信号を ADC に接続するために使用可能
Offset Compensation Freq
(オフセット補正周波数)
2
オフセットの補正間の ADC サンプル数を
設定
図 11. EzADC_1 ユーザー モジュールのパラメーター
PWM8_1 を変更して、そのパラメーターを表 4 のように変更します。変更した後、ウィンドウは図 12 のようになります。これで、
ユーザー モジュールの名称が LED1_PWM に変更されたことに注意してください。
表 4. LED1_PWM ユーザー モジュールのパラメーター
パラメーター
値
説明
Name (名称)
LED1_PWM
ユーザー モジュールに名称を付ける
Clock (クロック)
VC3
クロック ソースに VC3 を選択
Enable (イネーブル)
High (高)
連続カウントのために「High」を選択
CompareOut (比較出力)
Row_0_Output_2
行出力バスを介して比較出力を GPIO に接続
Terminal Count Out
(ターミナル カウント出力)
None (無)
これは補助カウンターであり、どの行出力バスにも接続する必要はない
Period (周期)
254
カウンターの周期を設定
Pulse Width (パルス幅)
127
PWM 出力のパルス幅 (50%デューティ サイクル) を設定
Compare Type (比較条件)
Less Than Or Equal (未満または
等しい)
比較機能の比較条件を選択
Interrupt Type (割り込みタイプ)
Terminal Count
(ターミナル カウント)
これを選択すると、カウンター レジスタのターミナル カウント時に割り
込みが発生される
Clock Sync
(クロック同期)
Sync to SysClK (SysClK と同期)
クロック入力をシステム クロックと同期化
Invert Enable
(イネーブル入力の反転)
Normal (通常)
イネーブル入力信号の極性を決定
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図 12. PWM_1 ユーザー モジュールのパラメーター
2.
PWM8_2 を選択して、そのパラメーターを 図 13 のように変更します。これで、ユーザー モジュールの名称が
LED2_PWM に変更されたことに注意してください。
図 13. PWM_2 ユーザー モジュールのパラメーター
3.
LCD_1 ユーザー モジュールを変更して、そのパラメーターを表 5 のように変更します。変更した後、ウィンドウは図 14
のようになります。
表 5. LCD_1 ユーザー モジュールのパラメーター
パラメーター
値
説明
Name (名称)
LCD_1
ユーザー モジュールに名称を付ける
LCD Port
(LCD ポート)
Port_2
LCD ディスプレイ モジュールを割り当て
られたポートへインターフェースさせる
BarGraph
(バー グラフ)
Disable
(無効)
バー グラフ機能を無効にする
図 14. LCD パラメーター
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4.
View > Global Resources を選択してグローバル リソース ウィンドウを開きます。ここで、ソース クロック VC3 を
PWM クロック周波数に、Ref Mux を ADC 入力データ範囲に設定します。他のパラメーターは初期値のままにします。
変更した後、グローバル リソース ウィンドウは図 15 のようになります。グローバル リソースの詳細情報については、
IDE ユーザー ガイドを参照してください。
図 15. グローバル リソースのパラメーター
7.3
PWM 信号のルーティング
本節では、PWM 信号を PWM ユーザー モジュールから選択された GPIO へ配線します。 GPIO ピン上の信号を見るには、
PWM 信号の配線を実装しなければなりません。
本設計はまた、2 つの PWM 出力を XOR ゲートに供給して論理レベルを行出力に実装します。XOR がとられる 2 つの
PWM 信号の周期差は、パルス (ハートビート) エフェクトを作り出します。
1.
LED1_PWM の CompareOut を Row_0_Output_2 に接続します。
2.
LED2_PWM の CompareOut を Row_0_Output_3 に接続します。
3.
自 動 ル ー テ ィ ン グ を 使 用 し て LED1_PWM の CompareOut を Port_1_2 に 接 続 し ま す 。 Shift を 押 し な が ら
LED1_PWM の CompareOut ピ ン を 選 択 し て 、 図 16 に 示 す よ う に そ れ を Port_1_2 と 接 続 し ま す 。 ま た 、
GlobleOutOdd_2 を使用して LED1_PWM を Port_1_2 に手動で接続できます。
図 16. 行出力に接続された PWM
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4.
Row_0_Output_2 デジタル相互接続をクリックして、図 17 に示すようにコンフィギュレーション オプションを開きます。
図 17. RO0[2]のデジタル相互接続ビュー
5.
LogicTable_Select (中央の四角形ボックスに示される) をクリックし、図 18 に示すようにドロップダウン リストから
A_XOR_B を選択して、Close をクリックします。
図 18. デジタル相互接続のコンフィギュレーション
6.
デジタル ルーティング図が図 19 のようになったことを確認してください。それらが一致していれば、パルス状のハート
ビート LED のコンフィギュレーションは完了しました。
図 19. Designer のチップ ビュー
7.4
コードの追加
このステップでは、点滅 LED を生み出すソフトウェア LED を実装するためにコードを追加して全てのユーザー モジュールと
GPIO をコンフィギュレーションします。以下のコードをプロジェクトの main.c ファイルに追加します。
1.
Workspace Explorer で、AN75320 Folder の下で Source Files フォルダを探して main.c ファイルを開きます。
2.
以下の C コードをコピーして main.c ファイルにある既存のコードを置き換えてペーストします。
コード 1. プロジェクト 1 の main.c
/* part specific constants and macros */
#include <m8c.h>
/* PSoC API definitions for all User Modules */
#include "PSoCAPI.h"
/* Definitions for all input and output operation */
#include "stdio.h"
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/* Macros to set ADC parameters */
#define GAIN
1
#define MAX_ADC_COUNTS
16383
#define ADC_RANGE
5000
/* Macros to select port 1 */
#define PORT_1_3
PRT1DR
/* Variable to store the ADC result */
WORD adc_result;
/* Variable to store the measured input in millivolts */
WORD v_in;
void main(void)
{
static unsigned int index;
/* Buffer used for the long to ASCII conversion */
char LCDBuffer[17];
/* Initializes LCD to use the multi-line 4-bit interface
LCD_1_Start();
*/
/* Enable global interrupts */
M8C_EnableGInt ;
/* Set the position to print the character */
LCD_1_Position(0,0);
/* print the Hello World in the first line */
LCD_1_PrCString("Hello World!");
/* Starts the LED1_PWM and LED2_PWM, high enable input begins the Counter */
LED1_PWM_Start();
LED2_PWM_Start();
/* Initializes and starts the EzADC User Module resources */
EzADC_1_Start(EzADC_1_HIGHPOWER);
/* Starts the ADC conversion */
EzADC_1_GetSamples(0);
while(1)
{
/* Wait for the ADC result to be available */
while(!(EzADC_1_fIsDataAvailable()));
/* Read the ADC result and clear the data ready flag */
adc_result = EzADC_1_iGetDataClearFlag();
/* Calculate input voltage in mV */
v_in = (DWORD)adc_result*ADC_RANGE / MAX_ADC_COUNTS / GAIN;
/* Convert the input voltage to an ascii string */
csprintf(LCDBuffer, "ADC INPUT:%4dmV", v_in);
/* Set the position to print the character */
LCD_1_Position(1,0);
/* print the voltage in the second line */
LCD_1_PrString(LCDBuffer);
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/* Toggle the pin 1[3]*/
PORT_1_3 ^= 0x08;
/* Give some delay to view toggling effect*/
for(index = 0; index < 22000; index++);
}
}
3.
7.5
local.mk ファイルをプロジェクトに追加して ADC の浮動小数点を有効にします。この機能の詳細情報については、
local.mk ファイルを見てください。
ピン配置のコンフィギュレーション
このステップでは、ピンが LED を駆動するよう GPIO ドライブ モードをコンフィギュレーションします。Pinout ビュー (View >
Pinout) で、選択したデバイスのピン配置をコンフィギュレーションします。Pinout パネルはワークスペースの左下に表示
されます。
1.
Pinout ビューで、P0[1]、P0[5]、P1[2]、および P1[3]のオプションを展開します。図 20 に示すようにピンをコンフィギュレーション
します。
図 20. ピン コンフィギュレーション
7.6
ビルドおよびプログラム
このステップでは、MiniProg1 デバイスをコンピュータに接続し、ビルドしたプロジェクトを PSoC デバイスにプログラムします。
1.
Build > Generate/Build ‘AN75320’ Project を選択する、または F6 を押します (図 21 を参照してください)。
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図 21. ビルドおよび生成オプション
2.
図 22 に示すように、出力ウィンドウは RAM/フラッシュの使用量およびエラーと警告の件数を含むビルドの状態を示します。
図 22. 出力ウィンドウ
3.
MiniProg1／MiniProg3 をコンピュータに接続します。
4.
MiniProg1／MiniProg3 を基板のプログラミング ヘッダーに接続します。詳細については、Error! Reference source
not found.のステップ 4 を参照してください。
5.
Program > Program Part を選択します (図 23 を参照してください)。図 24 に示すように、Program Part ウィンドウが
表示されます。
図 23. Program Part オプション
6.
Program Part ウィンドウで、以下を行ってください。
a)
Connect ボタン (Port Selection フィールドの隣にある) をクリックしてデバイスに接続します。
b)
MiniProg がデバイスへ電源を供給していて、デバイスへの電源を一旦切ってすぐに入れなおすことでデバイス
を選択する場合、Acquire Mode を Power Cycle に設定します。これは初期設定のオプションです。この
プロジェクトでは、初期設定のオプションを使用します。
c)
デバイスが外部から電源供給されていて、MiniProg がデバイスをリセットすることでのみデバイスを選択できる
場合は、Acquire Mode を Reset に設定します。
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7.
Program ボタンを押して、図 24 のようにデバイスをプログラムします。
図 24. プログラミングの状態
8.
7.7
プログラミングが完了した後、Power ボタンを押してデバイスの電源を切り替えます。これで、プログラマは基板の電源を
供給します。LED 点滅と退色を観察します。
CY3210-PSoCEval1 基板の設定
こ の デ モ は CY3210-PSoCEval1 ハ ー ド ウ ェ ア と 互 換 性 が あ り ま す 。 こ の キ ッ ト に 関 す る 詳 細 は 、
http://www.cypress.com/documentation/development-kitsboards/cy3210-psoceval1 をご覧ください。
図 25. CY3210-PSoCEval1 キット
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CY3210-PSoCEval1 キットをコンフィギュレーションしてプログラムする手順は以下の通りです。このキットには MiniProg や
ICE-Cube などのプログラミング デバイスが必要であることに注意してください。
1.
デモ基板にケーブルが一切接続されていない状態で、J1、J2 および J3 にはケーブルが差し込まれていないことを確認
します。
2.
P0[1]と VR 間を 1 本のワイヤで、P1[2]と LED1 間を 1 本のワイヤで接続し、P1[3]と LED2 間をもう 1 本のワイヤで
接続します (図 26 を参照してください)。
図 26. CY3210-PSoCEval1 のピン接続
3.
基板に搭載されているデバイスが CY8C29466-24PXI であることを確認します。
4.
基板に電源を供給するためには、MiniProg 1／MiniProg 3 をプログラミング ヘッダー (J11) に接続します。同様に、
12V の DC 電源をキット上の J10 に接続します。または、9V バッテリを J12 に接続することもできます。また、プログラミ
ング デバイスを J11 に接続します。外部の電源や電池を使用する場合ではリセット モードを使用します。基板の接続は
図 27 に示します。
図 27．電源とプログラム接続
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7.8
CY8CKIT-001 ボードの設定
CY8C29x66 プロセッサ モジュール 1 個を使用すると、このデモは CY8CKIT-001 ハードウェアとも互換性があります。この
キットに関する詳細は、http://www.cypress.com/?rID=37464 をご覧ください。
CY8CKIT-001 キットをコンフィギュレーションしてプログラムする手順は以下の通りです。このキットには MiniProg や ICECube などのプログラミング デバイスが必要であることに注意してください。さらに、このキットは ICE-Cube を使用する際に
オンチップ デバッグをサポートします。
図 28. CY8CKIT-001 キット
1.
デモ基板に一切ケーブルが接続されていない状態で、表 6 のようにジャンパを設定して開発基板をコンフィギュレーション
します。
表 6. ジャンパの設定
ジャンパ
2.
設定
VDD 選択 (SW3)
5V (上の位置)
5V ソース (J8)
VREG (上ピン 2 本)
VDD デジタル (J7)
VDD (上ピン 2 本)
VDD アナログ (J6)
VDD (上ピン 2 本)
LCD 電源 (J12)
ON (下ピン 2 本)
VDDIO 選択 (J2～J5)
VDD (左上ピン 2 本)
P0[1]と VR 間を 1 本のワイヤで、P1[2]と LED1 間を 1 本のワイヤで接続し、P1[3]と LED2 間をもう 1 本のワイヤで
接続します (図 29 を参照してください)。
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図 29. 別のピン接続図
3.
MiniProg や ICE などのプログラミング デバイスを PSoC 1 プロセッサ モジュールの J5 に接続します。
4.
12V DC 電源か 9V バッテリから基板へ電源を供給するか、またはプログラマからの電源を使用します。外部の電源や
電池を使用すると、リセット モードが使用されたことを確認してください。基板の接続については、図 30 を参照してください。
図 30. 電源とプログラム接続
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アプリケーションのテストにいずれの開発キットを使用した場合でも、以下を確認することが可能です。
8
1.
LCD ディスプレイが「Hello World」と「ADC INPUT:----mV」を表示します。
2.
1 個の LED が速く点滅します。
3.
2 個目の LED は、徐々に高くなり低くなる明度でパルスを発します。
まとめ
本アプリケーション ノートは PSoC 1 アーキテクチャおよび開発ツールを紹介しました。本書はまた、PSoC 1 プロジェクトを開
始するのに必要なツールについて説明しました。PSoC 1 は、単一のチップにコンフィギュレーション可能なアナログとデジタル
ペリフェラル機能、メモリ、M8C マイクロコントローラーを集積している真のプログラマブル組み込みシステムオンチップです。
本アプリケーション ノートはまた、PSoC 1 を迅速に深く理解できるように総合的なリソース収集へのアクセスを提供します。
説 明 し た 項 目 の 詳 細 情 報 に つ い て は 、 記 載 さ れ た リ ン ク や 参 照 文 献 を 参 照 す る 、 ま た は
http://www.cypress.com/products/psoc-1 を訪問してください。
9
関連アプリケーション ノート
本アプリケーション ノートは PSoC 1 の基本的な情報を含んでいます。特定のトピックに関する詳細情報については、特定の
アプリケーション ノートを参照してください。
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