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PSoC® 3 入门
作者： Nidhin MS
相关器件系列：所有 PSoC 3 器件
相关文档：请点击此处查看相关文档的完整列表。
想要获取本应用笔记的最新版本或相关项目文件，请访问 http://www.cypress.com/go/AN54181。
AN54181 介绍了 PSoC® 3，一个基于 8051 CPU 的可编程片上系统。它介绍了 PSoC 3 架构及其开发环境，并且展示
了如何使用 PSoC Creator™（即为 PSoC 3 的一种开发工具）来创建一个简单的设计。此外，本应用笔记还向您提供了
很多资源，用以深入了解有关 PSoC 3 以及通用的 PSoC 知识。
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简介
PSoC 3 是真正的可编程嵌入式片上系统，在同一芯片中集成了自定义的模拟和数字外设功能、存储器以及 8051
CPU。
PSoC 3 提供了一个经济实用的备用方案，可替换掉由一个 MCU 和外部 IC 构成的组合。PSoC 3 架构的性能通过以下
特性得到质的提升：




带有工作频率高达 67 MHz 的 DMA 控制器、数字滤波处理器以及 8 位 8051 内核
超低功耗，并拥有业界范围最大的工作电压
带有支持用户自定义的可编程数字和模拟外设
任何模拟或数字外设端口都可灵活路由至任意引脚
单个 PSoC 器件能够集成多达 100 种数字和模拟外设功能，因此它不但可以提高系统质量，而且能缩短设计时间、
节约电路板面积、降低功耗和系统成本。
如何使用本文档
下面几页详细介绍了 PSoC 3，并指出使用 PSoC 和 PSoC Creator 进行设计的优点。或者您可以跳转到 第一次进行的
PSoC 3 设计一节，以快速创建简单的设计。本节所创建的设计也可以在示例代码 CE203303 中找到。
www.cypress.com
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2
PSoC 资源
赛普拉斯的网站 www.cypress.com 上提供了大量资料，这些资料有助于您正确选择 PSoC 器件用于设计，并使您能够
快速和有效地将器件集成到设计中。有关资源的完整列表，请参考 KBA86521 — 如何使用 PSoC 3、PSoC 4 和
PSoC 5LP 进行设计。下面提供了 PSoC 3 的简要列表：



3
概况：PSoC 产品系列、PSoC 蓝图

产 品 选 型 ： PSoC 1 、 PSoC 3 、 PSoC 4 或
PSoC 5LP。此外， PSoC Creator 还包含了
一个器件选择工具。
技术参考手册（TRM）：对每个 PSoC 3、PSoC 4 和
PSoC 5LP 器件系列中所使用的架构和寄存器进行了详
细说明。

数据手册：描述并提供了适用于 PSoC 3、
PSoC 4 和 PSoC 5LP 器件系列的电气规范。
PSoC 培训视频：这些视频一步一步介绍了使用 PSoC
构建复杂设计的过程。

开发套件：

CapSense 设计指南：了解如何在 PSoC 3、
PSoC 4 和 PSoC 5LP 器件系列中设计电容式
触摸感应应用。

应用笔记和代码示例：包括从基本到高级的广
泛主题。许多应用笔记包括代码示例。
®

CY8CKIT-030 是专门为模拟性能而设计的。通过该
套件，您可以评估和开发高精度模拟、低功耗以及
低电压的各种应用。

CY8CKIT-001 提供一个通用的开发平台，通过它您
能够进行原型设计，并评估使用 PSoC 1、PSoC
3、PSoC 4 或 PSoC 5LP 架构的不同解决方案。
PSoC Creator
PSoC Creator 是一个基于 Windows 的免费集成开发环境（IDE）。通过它可以同时在 PSoC 3、PSoC 4 和 PSoC 5LP
器件中设计硬件和固件。如图 1 所示，通过 PSoC Creator，您可以进行以下操作：
1.
2.
将组件图标拖放到主设计工作区中，以进行您
的硬件系统设计。
协作设计您的应用固件和 PSoC 硬件
www.cypress.com
3.
使用配置工具配置各组件
4.
提供包含 100 多个组件的库
5.
查看组件数据手册
图 1. PSoC Creator 特性
文档编号：002-10298 版本**
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3.1
PSoC Creator 帮助
请访问 PSoC Creator 主页以下载 PSoC Creator 的最新版本。然后，启动 PSoC Creator，并逐步执行以下各项：
3.2

快速入门指南：依次选择菜单项 Help > Documentation > Quick Start Guide。本指南提供了开发 PSoC Creator
项目的基本知识。

简单的组件示例项目：依次选择菜单项 File > Open > Example projects。这些示例项目展示了如何配置及使用
PSoC Creator 组件。

入门设计：依次选择 File > New > Project > PSoC 3 Starter Designs。这些入门设计展示了 PSoC 3 的独特特
性。

系统参考指南：依次选择 Help > System Reference > System Reference Guide。该指南列出并描述了 PSoC
Creator 提供的系统功能。

组件数据手册：右击组件，然后选择“Open Datasheet”项。请访问 PSoC 3 组件的数据手册网页，获取所有
PSoC 3 组件的数据手册列表。

文档管理器：PSoC Creator 提供了一款文档管理工具，有助您寻找和查看文档资源。要想打开文档的管理工具，
请选择菜单项：Help >Document Manager。
技术支持
若有任何疑问，我们的技术支持团队很乐意为您提供帮助。您可以在 赛普拉斯技术支持页面上创建一个技术支持请
求。
如果您在美国，可以通过拨打我们的免费电话，直接与技术支持团队联系：+1-800-541-4736。提示音后选择 8。
若想快速获得支持，您同样可以使用下面的支持资源。


自助
所在地销售办事处
www.cypress.com
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4
代码示例
图 2. PSoC Creator 中的代码示例
PSoC Creator 包含了多个代码示例项目。可以从 PSoC Creator
的“Start Page”（起始页）上获取这些项目，如图 2 所示。
这些示例项目通过为您提供完整的设计（并非一个空白页），可以
加快您的设计过程。示例项目还介绍了如何将 PSoC Creator 组件
使用于不同应用中。此外，它还包含了多个代码示例和数据手册，
如图 3 所示。
在图 3 所示的 Find Example Project（查找示例项目）对话框中，
您可以选择以下选项：

根据 architecture（架构）或 device family（器件系列）（例
如：PSoC 3、PSoC 4 或 PSoC 5LP）；category（类型）或
keyword（关键词）等选项筛选示例


从 Filter Options（滤波选项）的示例菜单中进行选择。

查看选中的代码示例。您可以复制该窗口中的代码然后将其粘
贴到您的项目内，从而加快代码的开发过程，或

根据已选项目创建一个新的项目（若需要，可添加新的工作
区）。通过为您提供一个完整的基本设计，它可以加快您的设
计过程。然后，您可以根据自己的应用来调整该设计。
通过 Documentation（文档）选项卡，查看选中的数据手
册。
图 3. 带样本代码的代码示例项目
www.cypress.com
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5
PSoC 3 的功能集
PSoC 3 具有一个丰富的功能集，包括：一个 CPU 和存储器子系统、一个数字子系统、一个模拟子系统以及系统资
源，如图 4 所示（对于 CY8C38xx 器件系列）。
更多有关信息，请查看前面罗列的 PSoC 3 系列器件的数据手册、技术参考手册（TRM）和应用笔记。
图 4. PSoC 3 架构（CY8C38xx）
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以下是 PSoC 3 的主要特性列表。 请参见相关文档或参见 PSoC 3 器件的数据手册，以了解详细信息。


性能




工作频率范围：DC 至 67 MHz
8 位 8051 CPU，32 个中断
存储器


多达 64 KB 编程闪存


高达 8 KB 的 SRAM
24 通道直接存储器访问（DMA）控制器
24 位 64 抽头数字滤波处理器（DFB）
www.cypress.com
此外，还有高达 8 KB 的闪存空间，用于存储纠错码
（ECC）。
2 KB 的 EEPROM
文档编号：002-10298 版本**
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数字外设
多功能 I/O 系统

多达 4 个 16 位定时器、计数器和 PWM
（TCPWM）模块




I2C，1 Mbps 总线速度



获得认证的全速（FS）12 Mbp 的 USB 2.0
25 mA 灌电流
全速 CAN 2.0b 接口，16 个 Rx 缓冲区，8
个 Tx 缓冲区

可编程的输入阈值和输出高电压

可作为通用电压比较器使用
20 到 24 个 通用数字模块（UDB），通过配
置 UDB 模块，可以创建有限数量的如下功
能模块：



循环冗余校验（CRC）

伪随机序列（PRS）发生器

正交解码器

门限逻辑功能


具有 8 至 20 位可配置 delta-Sigma ADC
支持四个分辨率为 8 位的 DAC
支持四个电压比较器
支持四个运算放大器（opamp）
支持四个可编程模拟模块，用于创建：

可编程增益放大器（PGA）

互阻放大器（TIA）

混频器

采样和保持（S/H）电路
热交换功能和过压容限



可用作 GPIO 的两个 USBIO 引脚


所有 GPIO 均支持 CapSense 功能

模拟子系统





多达 8 个特殊性能 I/O（SIO）引脚

8、16、24 和 32 位定时器、计数器和
PWM
I2C、UART、SPI、I2S 和 LIN 2.0 接口

46 至 72 个 I/O 引脚，其中最多具有 62 个通用 I/O
（GPIO）
任意数字或模拟外设信号可以路由至任意 GPIO
任何 GPIO 都具有 LCD 直接驱动器功能，最多可驱动
46 × 16 行
接口电压范围为 1.2 V 至 5.5 V，多达 4 个电压域
可编程时钟

支持 3 到 62 MHz 内部振荡器，3 MHz 输出时精度为
1%



支持 4 到 25 MHz 外部晶振


支持 32.768 kHz 的外部时钟晶振
内部 PLL 能够生成高达 67 MHz 的时钟
频率分别为 1 kHz、33 kHz 和 100 kHz 的低功耗内部
振荡器
可布线到任何外设或 I/O 的 12 个时钟分频器
有关 PSoC 3 特性的完整信息，请参考其数据手册。
CapSense®支持，多大 62 个传感器
1.024 V ±0.1%内部参考电压
www.cypress.com
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5.1
PSoC 的性能比 MCU 的更优越
图 5 显示了一款典型的 MCU。它包含一个 CPU 和一系列外设功能（如：ADC、DAC、UART、SPI 和通用 I/O），
这些外设都与 CPU 的寄存器接口相连。在某个内部 MCU 中，可以将 CPU 称为该器件的“心脏”— 由于它监控着器
件的所有活动，包括：设置数据移动和时序。如果没有 CPU，那么该 MCU 便不能执行其性能。
图 6 中显示的 PSoC 则完全不同。CPU、模拟、数字和 I/O 是可编程系统 PSoC 中同样重要的资源。 PSoC 的“心
脏”是系统的互联和可编程性，并不是 CPU。模拟和数字外设通过高度可编程的路由矩阵互相连接，从而可创建完全
满足您应用需要的自定义设计。所以，可以编程 PSoC 模拟 MCU，但不能编程 MCU 来模拟 PSoC。
图 5．典型 MCU 结构框图
Gen I/O
Port B
Gen I/O
Digital System
(w/ Programmable Logic)
Gen I/O
UART
ADC
Gen I/O
Port A
图 6. PSoC 3 框图
Timer
Gen I/O
I2C
Gen I/O
SPI
ARM
CPU
DAC
8051
PWM
Analog System
Gen I/O
Port D
Gen I/O
Port C
Gen I/O
System Interconnect
Gen I/O
典型的 MCU 要求 CPU 固件处理状态机、使用定时器来进行计时、并驱动一个输出引脚。因此，其功能路径几乎都是
通过 CPU 实现的。通过使用 PSoC，可以进行异步并行操作。您可以配置 PSoC 中的组件，使其运行独立于 CPU。
比如，图 6 显示的 PSoC 3 没有 UART。但是，通过使用 PSoC Creator 中预设计和预测的 UART 组件，您可以在可配
置数字逻辑内配置无限量的 UART。您可以将每个 UART 配置为具有一些所需的特性。
5.2
PSoC Creator 组件的概念
对于成功的 PSoC 设计，最关键的就是 PSoC Creator IDE。PSoC Creator 将 PSoC 外设和其他资源组织为各个图形
元素（又称组件）。将各组件拖放到原理图内并将其连接起来，这样会使设计过程显得更加简单，并能够缩短设计时
间。只用点击几下就可以快速更改设计。
比如，对于传统的 MCU 而言，如需要使用 PWM 外设使 LED 闪烁发亮，您必须执行以下操作：
1.
确定对应于 PWM 的存储器的位置。
2.
根据所需 PWM 周期和占空比，计算需要写入到 PWM 寄存器内的值。
3.
编写许多代码行以便配置 PWM 寄存器，设置引脚驱动模式，并将 PWM 输出连接到该引脚上。
实现同 PSoC 的相同功能非常重要，您可以在下一节找到相关内容。
引脚组件：给任意引脚配置任意功能
PSoC 3 包含一个扩展布线结构，通过该结构可以将任意功能（模拟或数字）模块连接到某个引脚上。PSoC Creator
提供一个引脚组件，使您可以轻松地实现该操作。具体为：只需要点击几下就可以配置，连接至 PSoC 资源和某个物
理引脚上。您也很容易更改引脚组件连接，这样能够快速进行电路板等级的设计更改。
www.cypress.com
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基于可编程数字资源的组件
PSoC 3 具有可编程数字模块（称为通用数字模块，即 UDB）。PSoC Creator 提供了一些由 UDB 构成的组件。这些
组件包括 UART、SPI、I2C、I2S、定时器、PWM、计数器、CRC、正交解码器、数字门（AND、OR、NOT、
XOR），等等。您甚至可以创建自己的自定义状态机和数字逻辑。
基于可编程模拟资源的组件
PSoC 3 还具有可编程模拟模块（称为开关电容连续时间（SC/CT）模块）。PSoC Creator 提供由 SC/CT 模块构成的
模拟组件，比如：可编程增益放大器（PGA）和互阻放大器（TIA）。
6
第一次进行的 PSoC 3 设计
该章节包括以下内容：



6.1
演示了如何编程 PSoC，使其性能比传统 MCU 的更优越
说明了如何创建一个简单的 PSoC 设计，并将其安装在一个开发套件中
介绍了快捷了解使用 PSoC Creator IDE 来设计 PSoC（的技术）的详细步骤
入门
您是否已经安装好了 PSoC Creator？
在 PSoC Creator 主页上下载并安装 PSoC Creator。请注意，安装过程可能需要较长时间 — 具体情况请参考 PSoC
Creator 的发布说明。
您是否具有开发套件？
表 1 列出了赛普拉斯 PSoC 3 的所有开发套件。也可以从其他制造商中获得这些套件。
表 1. 赛普拉斯 PSoC 3 开发套件
PSoC 3 开发套件
PSoC 3 器件型号
编程工具
CY8CKIT-030
CY8C3866AXI-040
集成编程器
CY8CKIT-001
CY8C3866AXI-040
MiniProg3 编程和调试套件
您是否想查看正在操作的项目？
若不想进行下一节中的整个开发过程，您可以在 CE203303 上下载完整的代码示例项目。这样您可以跳转到构建和
编程步骤。该代码示例专门为基于 PSoC 5LP 的 CY8CKIT-059 设计；您很容易便能修改该示例，将其用于 PSoC 3 套
件。
www.cypress.com
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6.2
设计概况
在“CE203303 — PSoC 3 和 PSoC 5LP 呼吸 LED”代码示例中详细说明了该设计。该呼吸 LED 效果的实现完全基于
硬件，仅在初始化时才使用 CPU。图 7 显示的是 PSoC Creator 原理图。
图 7. 呼吸 LED 原理图（用于 CY8CKIT-059 的引脚和 LED）
6.3
第一部分：构建设计
本节将向您逐步介绍设计流程。本节内容指导您通过硬件和软件进行设计。
注释： 这些指导假设您正在使用 PSoC Creator 3.3。整个开发过程与其他 PSoC Creator 版本的相同，但是一些对话
框是不一样的。
1.
创建一个新的 PSoC Creator 工程。
一个项目包含所有源代码和其他文件用于创建单个输出模块，可以将该模块下载到目标 PSoC 3 器件中。
A.
启动 PSoC Creator。
图 8. 创建一个新的 PSoC Creator 项目
B.
依次选择
File > New > Project…，如图 8 所示。
将出现创建项目窗口。
www.cypress.com
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2.
将 PSoC 3 选择为目标器件。请参考图 9。
PSoC Creator 可以根据所指定的目标器件或开发套件自动设置各种项目选项，从而加快开发过程。
A.
点击 Target device（目标器件）。
B.
选定下拉菜单中的 PSoC 3。
C.
然后点击 Next 按键。
图 9. 为 CY8CKIT-059 创建新的项目
A
B
C
www.cypress.com
文档编号：002-10298 版本**
10
®
PSoC 3 入门
3.
选择一个空白原理图作为一个项目模板使用。请参考图 10。
PSoC Creator 根据现有的代码示例进行新设计，从而加快开发进度。对于该示例，我们将从一个空白的原理图
开始。
A.
点击 Empty Schematic。
B.
然后点击 Next 按键。
C.
在下一个对话框的 Workspace name 框中，输入工作区名称。一个工作区中包含了一个或多个项目。一个项
目通常处于一个工作区中。
D.
在 Project name 框中输入项目名称。项目名称与工作区名称可以相同，也可以不同。
E.
指定您工作区和项目的 Location（位置）。
F.
点击 Finish。
图 10. 创建一个新的空白项目
A
B
C
D
E
F
www.cypress.com
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创 建 了 一 个 项 目 。 一 些 新 的 面 板 将 会 显 示 ： Workspace Explorer 、 Schematic （ TopDesign.cysch ） 和
Component Catalog。
4.
对设计中的硬件部分进行构建。
在该步骤中，您将组件目录中的组件拖放到原
理图中。然后，配置每个组件，并将其连接
起来。
a.
在 Component Catalog 窗 口 的
Cypress 选项卡中，寻找 PWM 组件，
如图 11 所示。
b.
将 PWM 组件的两个实例拖放到原理图中
（请参考图 7）。
www.cypress.com
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5.
配置 PWM 组件，如图 12 所示。
这样将创建两个 PWM 方波，但它们的工作频率略有不同。该频率差异会导致在 LED 上实现调制拍频。
在原理图中，双击每个 PWM 组件以对其进行配置。
A.
对于 PWM_1，在 PWM Mode 框中选择 One Output。
B.
不需要对 PWM_1 进行其它更改。点击 OK，关闭该对话框。
C.
对于 PWM_2，在 PWM Mode 框中选择 One Output。
D.
将 PWM_2 的 Period 设置为不同于默认值的数值。
E.
将 PWM_2 的 CMP Value 1 值设置为“周期”值的一半。
F.
对 PWM_2 进行的更改已完成。点击 OK，关闭该对话框。
图 12. PWM 组件的配置
C
A
D
E
B
F
6.
将组件从组件目录拖放到原理图中并将其配置，表 2 已列出了其他组件。
不需要 Off-Chip 组件，但这些组件将帮助显示设计的总体目的。
注意：在每个配置对话框中，Name 字段被自动填充；您可以将名称更改为任何一个有效文本。在原理图中每个组
件的名称是唯一的。
表 2. 设计组件
组件目录
组件
www.cypress.com
选项卡
组合
更改默认配置
低逻辑
赛普拉斯
数字 > 逻辑
无
Xor
赛普拉斯
数字 > 逻辑
无
时钟
赛普拉斯
系统
将 Frequency（频率）设置为 5 kHz
数字输出引脚
赛普拉斯
端口和引脚
检查 External terminal 框
电阻
片下
被动
无
LED
片下
二极管
无
接地
片下
供电
无
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7.
选择连线工具（图 13），连接这些逻辑（也
可以使用快捷键‘w’）。
图 13. 选择连线工具
将各组件互连在一起，如图 7 所示。
8.
这时便完成了硬件设计，但还需要为引脚组件分配一个物理引脚。
为您正在使用的开发套件中的 LED 选择物理引脚。（对于 CY8CKIT-030，所使用的引脚可以是端口 6 的引脚 2 或
引脚 3，也被称为 P6[2]或 P6[3]）。
A.
在工作区浏览器窗口上，双击您项目中的 .cydwr 文件，如图 14 所示。这样可打开设计范围资源（DWR）窗
口。
B.
选择 Pins 选项卡。这时将显示项目中定义的引脚组件以及目标器件的引脚框图。
C.
将原理图中的引脚组件分配给所需物理引脚。
图 14. 分配引脚
A
C
B
9.
您现在需要编写几行固件。编写固件前，PSoC Creator 最好要生成所有与组件相应的代码。
选择 PSoC Creator 菜单项 Build > Generate
Application，如图 15 所示。如果没有出现错
误，则 PSoC Creator 会生成几个代码文件，
这些文件位于 Generated_Source 文件夹中。
www.cypress.com
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10. 将代码添加到自动生成的文件 main.c 中。有一个用于添加代码的框架；您需要添加的代码（用于启动两个 PWM
组件）被高亮显示，如代码 1 所示。在工作区浏览器窗口上，双击您项目中的 main.c 文件以打开它。
注释： 该代码假设 PWM 组件具有默认名称。如果您想重新命名 PWM 组件，而不是使用默认名称，则使用 _Start()函
数条用的名称。
代码 1. 呼吸 LED 的主代码
#include <project.h>
int main()
{
//CyGlobalIntEnable; /* Enable global interrupts. */
/* Place your initialization/startup code here (e.g. MyInst_Start()) */
PWM_1_Start();
PWM_2_Start();
for(;;)
{
/* Place your application code here. */
}
}
11. 如果您没有遵循设计的整个流程而跳到这一步，请执行下列操作：
A.
从 CE203303 上下载 CE203303.zip 代码示例文件，然后将其解压到您的电脑中容易找到的位置。
B.
下载并安装 PSoC Creator，如第 9 页上的第 1 步所示。
C.
打开 PSoC Creator 中的 CE203303.cywrk 文件。
D.
确认该项目引脚分配与您的开发套件（DVK）互相匹配，如第 14 页上的第 8 步所示。
E.
在工作区浏览器窗口上，右击项目名称，
然 后 选 择 Device Selector 项 中 的
“CY8C3866AXI-040”，将其作为目标
器件。
F.
依次选择 PSoC Creator 菜单项 Build >
Build <project name>，如图 16 所示。
如果没有出现错误，则该项目已经创建
好，并准备编程目标的开发板
（DVK）。
www.cypress.com
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6.4
第二部分：为器件编程
所有开发板的编程过程都一样。请按照套件指南材料中介绍的指导进行设置您的开发板。
1.
确认 PSoC Creator 和您的 DVK 之间的连接状态。
依次选择 PSoC Creator 菜单项 Debug >
Select Debug Target，如图 17 所示。
A.
“Select Debug Target”对话框将会显
示，如图 18 所示。点击您的目标 DVK
（PSoC Creator 支持多个 DVK 连接）。
B.
点击 Port Acquire 项。
图 17. 选择调试目标
图 18. 选择并获取调试目标以进行编程
A
B
www.cypress.com
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2.
将 PSoC 连接到您的目标 DVK。请参考图 19。
A.
点击 PSoC 3。
B.
点击 Connect。“Target unacquired”（未获取调试目标）信息将会更改为“Target acquired”（已获取调
试目标），并且按键的标签会更改为“Disconnect”（断开连接）。
C.
点击 OK，关闭该对话框。
PSoC Creator 已连接到目标 DVK 和 PSoC，您现在可以对 PSoC 进行编程。
图 19. 连接到目标 PSoC 3
A
B
C
3.
如需要编程 PSoC 3，请选择 PSoC Creator
菜单项 Debug > Program，如图 20 所示。
4.
开 始 编 程 。 您 可 以 在 窗 口 左 下 角 的 PSoC
Creator 状态栏上查看编程的状态，如图 21
所示。
图 20. 编程器件
注释： 您也许看到以下警报信息：“当前该
编程器已过期”。更多有关如何升级您的编程
器固件的信息，请参考套件文档中的 KitProg
用户指南。
图 21. 编程状态
在 CY8CKIT-030 DVK 上，红色 LED 将在几秒的时间内逐渐从全亮转到全灭。
www.cypress.com
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7
总结
本应用笔记展示了 PSoC 3 架构和开发工具。通过本应用笔记，需要了解的最关键概念是：PSoC 的性能比 MCU 的更
好。PSoC 3 是真正的可编程嵌入式片上系统，在同一个芯片中集成了可配置的模拟和数字外设功能、存储器以及
8051 CPU。
由于具有集成特性以及低漏功耗模式，因此 PSoC 3 是低功耗和经济高效嵌入式系统的理想选择。
8
相关文档
表 3 列出了推荐的系统级和通用的应用笔记，用以进一步了解 PSoC 和 PSoC Creator。
表 3. 通用和系统级应用笔记
文档
文档名称
AN61290、
AN88619
PSoC 3 和 PSoC 5LP 硬件设计中的注意事项、
®
PSoC 4 硬件设计中的注意事项
AN81623
PSoC 3、PSoC 4 和 PSoC 5LP 数字设计的最佳实践
AN77900、
AN86233、
AN90114
PSoC 3 和 PSoC 5LP 低功耗模式和降低功耗技术、
®
PSoC 4 低功耗模式和降低功耗技术、
®
PSoC 4000 低功耗模式和降低功耗技术
AN68403
PSoC 3 和 PSoC 5LP 模拟信号链路校准
AN57821
PSoC 3、PSoC 4 和 PSoC 5LP 混合信号的电路板布局注意事项
AN58827
PSoC 3 和 PSoC 5LP 内部模拟布线的注意事项
AN73854
PSoC 3、PSoC 4 和 PSoC 5LP 中实现的 Bootloaders 的说明
AN60616
PSoC 3 和 PSoC 5LP 启动程序
AN60631
PSoC 3 和 PSoC 5LP 时钟资源
AN77835
从 PSoC 3 升级到 PSoC 5LP 的指南
AN78175、
AN89056
PSoC 3 和 PSoC 5LP IEC60730 B 类安全软件库、
®
PSoC 4 IEC60730 B 类和 IEC61508 SIL 安全软件库
®
®
®
®
®
®
®
®
®
®
®
表 4 列出了各种应用笔记（AN）、代码示例（CE）和知识库文章（KBA），这些文档被链接到 PSoC 3 的功能集所列
的器件描述。
表 4. PSoC 3 特性相关文档
文档
文档名称
CPU 和中断
®
AN60630
PSoC 3 8051 代码和存储器优化
AN54460
PSoC 3 和 PSoC 5LP 中断
®
存储器
CE95313
®
PSoC 3、PSoC 4 和 PSoC 5LP 仿真 EEPROM 存储器
直接储存器访问（DMA）
®
AN52705
PSoC 3 和 PSoC 5LP：DMA 入门
AN84810
PSoC 3 和 PSoC 5LP DMA 的高级主题
www.cypress.com
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文档
文档名称
AN61102
PSoC 3 和 PSoC 5LP：使用 DMA 来缓冲 ADC 数据
CE95375
CE95376
PSoC 3 和 PSoC 5LP 的 SPI 主设备和 DMA
®
PSoC 3 和 PSoC 5LP 的 SPI 从设备和 DMA
®
®
数字滤波器模块（DFB）
®
CE95316
在 PSoC 3 和 PSoC 5LP 中使用 DFB 过滤 ADC 并将其转换为 VDAC
CE95317
PSoC 3 和 PSoC 5LP 在轮询模式下使用 DFB 过滤 ADC 并将其转换为 VDAC
®
I2C
®
2
CE95324
PSoC 3 和 PSoC 5LP 的 I C LCD
CE95314
PSoC 3、PSoC 4 和 PSoC 5LP EZI2C
®
USB
AN57294
USB 101：通用串行总线 2.0 的简介
AN57473
PSoC 3 和 PSoC 5LP 的 USB HID 初级
AN58726
PSoC 3 和 PSoC 5LP 的 USB HID 中级
AN56377
PSoC 3 和 PSoC 5LP：实现 USB 数据传输的介绍
AN82072
PSoC 3 和 PSoC 5LP 中使用标准 HID 驱动器的 USB 通用数据传输
AN73503
PSoC 3 和 PSoC 5LP 的 USB HID Bootloader
CE95390
PSoC 3 和 PSoC 5LP 的 USB Audio
CE95395
PSoC 3 和 PSoC 5LP 的 USB MIDI
CE95394
PSoC 3 和 PSoC 5LP 的 USB HID 鼠标
CE95393
PSoC 3 和 PSoC 5LP 的 USB 批量传输
CE95392
PSoC 3 和 PSoC 5LP 的 USB Bootloader
CE95396
PSoC 3 和 PSoC 5LP 的 USB UART
®
®
®
®
®
®
®
®
®
®
®
控制器区域网络（CAN）
®
AN52701
PSoC 3 和 PSoC 5LP：控制器局域网络（CAN）入门
CE95282
PSoC 3 和 PSoC 5LP 中通过 CAN 实现控制节点
CE95283
PSoC 3 和 PSoC 5LP 中通过 CAN 删除节点
KBA86565
Full CAN 和 Basic CAN 邮箱之间的差别
KBA86566
针对 CAN 的接收信息采用验收滤波器
KBA86567
在编程过程中修改 Full CAN 邮箱的标识符
®
®
通用数字模块（UDB）
®
AN82250
使用 Verilog 实现 PSoC 3、PSoC 4 和 PSoC 5LP 的可编程逻辑设计
AN82156
使用 UDB 数据路径对 PSoC 3、PSoC 4 和 PSoC 5LP 的 PSoC Creator
CE95295
PSoC 3 和 PSoC 5LP 的 8 位 UDB 计数器
CE95384
PSoC 3 和 PSoC 5LP 中基于 UDB 的 16 位定时器
CE95323
PSoC 3 和 PSoC 5LP 的硬件风扇控制
www.cypress.com
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文档
文档名称
KBA85325
PSoC 3 和 PSoC 5LP 的 UDB 资源利用率与其他供应商 CPLD 的比较
KBA86336
PSoC 的 Verilog 基本知识
®
®
模数转换器（ADC）
®
AN84783
使用 PSoC 3 和 PSoC 5LP 的 Delta-Sigma 模数转换器（ADC）提高测量准确度
CE95277
PSoC 3 和 PSoC 5LP 中单端模式下的 Delta-Sigma 模数转换器
CE95271
PSoC 3 和 PSoC 5LP 中差分模式下的 Delta-Sigma 模数转换器
CE95276
PSoC 3 和 PSoC 5LP 的序列 SAR 模数转换器（ADC）
KBA81866
在 PSoC 3 和 PSoC 5LP 中选择最佳放大方法以获得更好的 Delta-Sigma 模数转换器性能
KBA84753
在 PSoC 3、PSoC 4 和 PSoC 5LP 中选择参考电压以获取准确的 ADC 测量
®
®
®
®
®
数模转换器（DAC）
®
AN60305
使用 PSoC 3 和 PSoC 5LP 的 IDAC 来构建更好的 VDAC
AN64275
PSoC 3 和 PSoC 5LP：提高 8 位 DAC 的分辨率
AN69133
PSoC 3 和 PSoC 5LP 中通过 WaveDAC8 组件更容易生成波形
CE95397
PSoC 3 和 PSoC 5LP 的电压 DAC
CE95309
PSoC 3 和 PSoC 5LP 的抖动电压 DAC
KBA84732
PSoC 3 和 PSoC 5 的 VDAC8 输出电压
KBA83238
使用 PSoC 3 或 PSoC 5 中的 VDAC 来驱动外部负载
®
®
®
®
®
®
比较器
®
AN60220
PSoC 3 和 PSoC 5LP 的复用比较器
CE95292
PSoC 3 和 PSoC 5LP 的模拟电压比较器
CE95361
PSoC 3 和 PSoC 5LP 中使用内部 VDAC 来扫描比较器
CE95360
PSoC 3、PSoC 4 和 PSoC 5LP 在通用模式下扫描比较器
®
®
®
运算放大器（Opamp）
CE95339
®
PSoC 3 和 PSoC 5LP 的运算放大器（Opamp）
可编程模拟模块（SC/CT）
®
AN60321
PSoC 3 和 PSoC 5LP 的峰值检测
AN62582
AM 调制和解调
CE95342
PSoC 3 和 PSoC 5LP 的可编程增益放大器
CE95343
PSoC 3 和 PSoC 5LP 的反相可编程增益放大器
CE95383
PSoC 3 和 PSoC 5LP 的互阻放大器（TIA）
CE95357
PSoC 3 和 PSoC 5LP 的采样和保持
CE95337
PSoC 3 和 PSoC 5LP 的模拟信号混频器
®
®
®
®
®
CapSense
®
®
AN75400
PSoC 3 和 PSoC 5LP CapSense 设计指南
CE95287
PSoC 3 和 PSoC 5LP 中使用调谐器的 CapSense CSD
www.cypress.com
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文档
文档名称
CE95284
PSoC 3 和 PSoC 5LP 的 CapSense CSD 设计
®
®
I/O
®
AN72382
使用 PSoC 3 和 PSoC 5LP GPIO 引脚
AN60580
PSoC 3 和 PSoC 5LP 中 SIO 的提示和技巧
KBA82883
使用固件控制 PSoC 3 和 PSoC 5LP 的 GPIO
KBA91716
PSoC 3 和 PSoC 5LP 中 SIO 和 GPIO 引脚之间的差别
®
®
®
段式 LCD
®
AN52927
PSoC 3 和 PSoC 5LP — 段式 LCD 直接驱动
CE95368
PSoC 5 段式 LCD
®
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全球销售和设计支持
赛普拉斯公司具有一个由办事处、解决方案中心、厂商代表和经销商组成的全球性网络。要想查找离您最近的办事处，请访问
赛普拉斯办公所在地。
PSoC®解决方案
产品
汽车级产品
cypress.com/go/automotive
psoc.cypress.com/solutions
时钟与缓冲区
cypress.com/go/clocks
PSoC 1 | PSoC 3 | PSoC 4 |PSoC 5LP
接口
cypress.com/go/interface
赛普拉斯开发者社区
照明与电源控制
cypress.com/go/powerpsoc
cypress.com/go/plc
社区 | 论坛 | 博客 | 视频 | 培训
存储器
cypress.com/go/memory
技术支持
PSoC
cypress.com/go/psoc
cypress.com/go/support
触摸感应
cypress.com/go/touch
USB 控制器
cypress.com/go/usb
无线/射频
cypress.com/go/wireless
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