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Copyrights
© Cypress Semiconductor Corporation, 2011. The information contained herein is subject to change without notice. Cypress
Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a Cypress
product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor
intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express
written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in lifesupport systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The
inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use
and in doing so indemnifies Cypress against all charges.
Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by
and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty
provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create
derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom software and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as specified in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this Source
Code except as specified above is prohibited without the express written permission of Cypress.
Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATERIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described
herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein.
Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure
may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all
charges.
Use may be limited by and subject to the applicable Cypress software license agreement.
PSoC® and CapSense® are registered trademarks and PSoC Designer™ is a trademark of Cypress Semiconductor Corp. All
other trademarks or registered trademarks referenced herein are property of the respective corporations.
Flash Code Protection
Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its
family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.
There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our
knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as ‘unbreakable’.
Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly
evolving. We at Cypress are committed to continuously improving the code protection features of our products.
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1.
Introduction
Thank you for your interest in the CY3280-20x66 Universal CapSense® Controller Kit. This kit is
designed for easy prototyping and debug of the 20xx6A CapSense family designs using predefined
control circuitry and plug-in hardware. The kit includes programming hardware and a CY3240-I2USB
bridge for tuning and data acquisition. This module connects to any CY3280 Universal CapSense
Module board.
This document describes the CY3280-20x66 Universal CapSense Controller kit and describes the
code examples provided with the kit. ‘CY3280_20x66 CSD PD Project1’ is the default project programmed on the CY3280-20x66 Universal CapSense Controller board. For more information on this
project, see the Code Examples chapter on page 31.
1.1
Kit Contents
The CY3280-20x66 Universal CapSense Controller Kit contains:
■
CY3280-20x66 Universal CapSense Controller board
■
CY3240-I2USB bridge board
■
MiniProg1 programmer
■
USB A to Mini B cable
■
CY8C20466A-24LQXI sample silicon
■
CY3280-20x66 Universal CapSense Controller Kit CD
❐
PSoC Designer installation file
❐
PSoC Programmer installation file
❐
Bridge Control Panel installation file (packaged along with PSoC Programmer)
❐
Code examples
❐
Hardware files
❐
Kit guide
❐
Quick start guide
❐
Release notes
Inspect the contents of the kit. If any parts are missing, contact your nearest Cypress sales office for
further assistance.
1.1.1
Prerequisites
The following are required for the functioning of the kit:
■
CY3280 Universal CapSense Module board or user custom board similar to CY3280 module
boards (see CY3280 Universal CapSense Module Boards on page 6
■
12 V DC adapter (optional)
■
CY3215 DK (optional, required to debug programs in PSoC Designer)
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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Universal CapSense Module boards are available for purchase separately or as part of the combination kits. Visit http://www.cypress.com/go/shop for more information.
1.1.2
MiniProg1 Programmer
The PSoC MiniProg gives you the ability to program PSoC parts quickly and easily. It is small,
compact, and connects to your PC using the provided USB 2.0 cable. During prototyping, the
MiniProg can be used as an in-system serial programmer (ISSP) to program PSoC devices on your
PCB.
When the MiniProg is connected, you can use PSoC Programmer to program. PSoC Programmer is
a free software, which can either be launched from within PSoC Designer or run as a standalone
program.
1.1.3
CY3240-I2USB Bridge
The I2USB bridge allows you to test, tune, and debug hardware and software of a PSoC application
by bridging the USB port to I2C. Populated with the CY8C24894 PSoC device, the I2USB bridge can
be connected through the ISSP pins on the controller board.
1.1.4
CY3280 Universal CapSense Module Boards
CY3280 Universal CapSense Module boards are available for purchase separately or as part of the
combination kits. The CY3280-20x66 Universal CapSense Controller can be connected to CY3280SLM, CY3280-SRM, CY3280-BMM, and CY3280-BSM CapSense boards.
1.2
PSoC Designer
PSoC Designer is the integrated development environment (IDE) used to customize your PSoC
application. More information about the PSoC Designer is available in the PSoC Designer IDE
Guide; go to: <Installed_directory>\Cypress\PSoC Designer\<version>\Documentation.
1.3
PSoC Programmer
PSoC Programmer offers a simple GUI to configure and program PSoC devices.
1.4
Bridge Control Panel
The Bridge Control Panel GUI is used with CY3240-I2USB bridge to enable communication with I2C
slave devices; here, it is used with the CY3280-20x66 Universal CapSense Controller. This software
is used to configure I2C devices as well as acquire and process data received from I2C slave
devices. The Bridge Control Panel helps in optimizing, debugging, and tuning the target devices.
1.5
Additional Learning Resources
Visit http://www.cypress.com for additional learning resources in the form of data sheets, technical
reference manual, and application notes.
1. CY8C20X36A/46A/66A/96A CapSense Applications - http://www.cypress.com/?rID=38222
This is the PSoC CY8C20066 data sheet that contains pin descriptions and other specifications
of the PSoC CY8C20066
2. CY3280-20x66 Universal CapSense Controller Board Layouts http://www.cypress.com/?rID=38222
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3. CY3280-20x66 Universal CapSense Controller Schematics http://www.cypress.com/?rID=38222
4. CY3240-I2USB Bridge Guide - http://www.cypress.com/?rID=3421
5. CY3280-SLM Linear Slider Module Kit - http://www.cypress.com/go/CY3280-SLM
6. CY3280-SRM Radial Slider Module Kit - http://www.cypress.com/go/CY3280-SRM
7. CY3280-BSM Simple Button Module Kit - http://www.cypress.com/go/CY3280-BSM
8. CY3280-BMM Matrix Button Module Kit - http://www.cypress.com/go/CY3280-BMM
9. MiniProg Users Guide and Code Examples - http://www.cypress.com/?rID=3412
10.PSoC Designer Training - http://www.cypress.com/?rID=40543
This is a web-based course that provides an overview of PSoC and its design tools
1.6
Document History
**
PDF Creation
Date
02/17/2011
Origin of
Change
RKPM
*A
06/10/2011
SASH
Revision
1.7
Description of Change
Initial version of kit guide
Added section 5.1 My First Code Example.
Text and image updates throughout the document.
Documentation Conventions
Table 1-1. Document Conventions for Guides
Convention
Usage
Courier New
Displays file locations, user entered text and source code:
C:\...cd\icc\
Italics
Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.
[Bracketed, Bold]
Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]
File > Open
Represents menu paths:
File > Open > New Project
Bold
Displays commands, menu paths and icon names in procedures:
Click the File icon and then click Open.
Times New Roman
Displays an equation:
2+2=4
Text in gray boxes
Describes cautions or unique functionality of the product.
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2.
Getting Started
This chapter describes the installation and configuration of the CY3280-20x66 Universal CapSense
Controller Kit.
2.1
Kit Installation
To install the kit software, follow these steps:
1. Insert the kit CD into the CD drive of your PC. The CD is designed to auto-run and the kit installer
startup screen appears.
Note You can also download the latest kit installer from http://www.cypress.com/go/CY328020x66. Three different types of installers are available for download.
a. CY3280-20x66_ISO: This file (ISO image) is an archive file of the optical disc provided with
the kit. You can use this to create an installer CD or extract information using WinRar or similar tools.
b. CY3280-20x66_ Single Package: This executable file installs the contents of the kit CD, which
includes PSoC Programmer, PSoC Designer, kit code examples, kit hardware files, and user
documents.
c. CY3280-20x66_Single Package (without prerequisites): This executable file installs only the
kit contents, which includes kit code examples, hardware files, and user documents.
2. Click Install the CY3280-20x66 to start the installation, as shown in Figure 2-1.
Figure 2-1. Kit Installer Startup Screen
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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Note If auto-run does not execute, double-click cyautorun.exe in the root directory of the CD, as
shown in Figure 2-2.
Figure 2-2. Root Directory of the CD
3. The Install Shield Wizard screen appears. The default setup location is shown on the Install
Shield Wizard screen. You can change the location using Change, as shown in Figure 2-3.
4. Click Next to launch the kit installer.
Figure 2-3. Install Shield Wizard
5. In the Product Installation Overview screen, select the installation type that best suits your
requirement. The drop-down menu has three options - Typical, Complete, and Custom, as
shown in Figure 2-4.
6. Click Next to start the installation.
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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Figure 2-4. Installation Type Options
7. When the installation begins, a list of packages appear on the Installation Page. A green check
mark appears adjacent to every package that is downloaded and installed (see Figure 2-5).
8. Wait until all the packages are downloaded and installed successfully.
10
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Figure 2-5. Installation Page
9. Click Finish to complete the installation.
Figure 2-6. Installation Completion Page
After software installation, verify your setup by opening PSoC Programmer with the MiniProg
attached to PC. Open Bridge Control Panel with the I2USB bridge attached to the PC to verify driver
installation.
Note Advanced users can skip to Code Examples chapter on page 31.
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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2.2
PSoC Designer
1. Click Start > All Programs > Cypress > PSoC Designer <version> > PSoC Designer <version>.
2. Click File > New Project to create new project; click File > Open Project to work with an existing
project.
Figure 2-7. PSoC Designer Interconnect View
3. To experiment with the code examples, go to Code Examples chapter on page 31.
Note For more details on PSoC Designer, see the PSoC Designer IDE Guide at:
<Install_directory>\Cypress\PSoC Designer\<version>\Documentation.
See Additional Learning Resources on page 6 for links to PSoC Designer training.
The PSoC Designer quick start guide is available at: http://www.cypress.com/?rID=47954.
12
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2.3
PSoC Programmer
1. Click Start > All Programs > Cypress > PSoC Programmer <version> > PSoC Programmer
<version>.
2. Select the MiniProg from the port selection, as shown in Figure 2-8.
Figure 2-8. PSoC Programmer Window
3. Click the File Load button from Programmer menu bar, navigate and select the hex file.
4. Use Program button to program the hex file on to the chip.
5. When programming is successful, Programming Succeeded appears in the Actions pane.
6. Close PSoC Programmer.
Note For more details on PSoC Programmer, go to Programmer user guide at:
<Install_directory>\Cypress\Programmer\<version>\Documents.
2.4
Bridge Control Panel
1. Click Start > All Programs > Cypress > Bridge Control Panel <version> > Bridge Control
Panel <version>.
2. Select 5.0V from Power Setting box, as highlighted in Figure 2-9.
3. Select the device to be connected from the port window.
4. Click the Variable Settings option from the Chart menu, click Load, navigate to and open the
*.ini file.
5. Select File > Open; navigate to and open the *.iic file. The iic file contents appear on the Editor
pane of the Bridge Control Panel.
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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Figure 2-9. Selecting the Bridge
Note For more details on the Bridge Control Panel, view the help topics from the Bridge Control
Panel Menu bar.
14
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3.1
Kit Operation
Introduction
The CY3280-20x66 Universal CapSense Controller (UCC) connects to any CY3280 Universal
CapSense Module board. This kit requires PSoC Designer for development, PSoC Programmer for
programming, and Bridge Control Panel to test and tune the CapSense parameters.
3.2
3.3
Hardware Requirement
■
CY3280-20x66 Universal CapSense Controller board (PSoC Device ID: CY8C20066A-24LTXI)
■
CY3280-Universal CapSense Linear Slider board or a similar CapSense module board
■
MiniProg1
■
CY3240-I2USB bridge
■
USB A to Mini-B cable
Connecting CapSense Module Board
The CY3280-Universal CapSense Linear Slider Module Board can be connected to the UCC
through Port P2 of the UCC board and J1 of the CY3280 Universal CapSense Linear Slider Module.
The connection is as shown in the following figure.
Figure 3-1. Connect CapSense Module Board to Universal CapSense Controller.
On the CY3280-20x66 Universal CapSense Controller board, place shunts on pins 1 to 2 of J4
(XRES select). On the CY3280-SLM Universal CapSense Linear Slider Module, place a shunt on
pins 2 and 3 of J2.
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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3.4
Programming PSoC with New Design
The CY3280-20x66 Universal CapSense Controller is programmed using a MiniProg1 provided with
the kit.
Figure 3-2. Connect MiniProg to Controller
1. Connect the USB port of your PC to the CY3280-20x66 ISSP connector (J3) using the PSoC
MiniProg and a USB cable (A to Mini B). Programming can be done using PSoC Programmer.
2. On the UCC, connect J7 to pin 2 of J1. This enables power supply by the MiniProg1.
3. Toggle the Power button on PSoC Programmer.
4. LED D1 on the CY3280-20x66 Universal CapSense Controller is on if powered with Vcc_Prog.
Otherwise, both LEDs D1 and D2 light up on powering the device with other power sources.
5. Program the hex file onto the CY3280-20x66 Universal CapSense Controller board using the
MiniProg. While programming is in progress, the Target Power LED on the MiniProg is on, as
shown in Figure 3-2.
Note Hex files are available in the installed directory and in the kit CD.
6. When Programming Succeeded appears in the Actions pane, detach the MiniProg and connect
an I2USB bridge to the ISSP connector.
7. Connect your computer to the CY3280-20x66’s ISSP connector using the I2USB bridge and a
USB cable, as shown in Figure 3-3.
Figure 3-3. Connect I2USB Bridge to Controller
16
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3.5
Bridge Control Panel
The I2USB bridge is used to read the CapSense parameters from the controller board. These
parameters can be viewed using the Bridge Control Panel software. Follow these steps to use the
Bridge Control Panel software with the CY3280-20x66 Universal CapSense Controller board.
1. Click Start > All Programs > Cypress > Bridge Control Panel <version>.
2. Select the device to be connected from the port selection window.
3. Select Variable Settings option from the Chart menu. Load the .ini file, by clicking the Load button.
The CY3280_SLM_Project1.ini file is the variable setting file, available in the kit CD or at the following location: <Install_Directory>\Cypress\CY3280-20X66\<version>\Firmware\I2C-USBBridgeSoftwareConfig.
4. Load the CY3280_SLM_Project1.iic file for iic commands that can be sent to the board.
The .iic file is the configuration setting file, available in the kit CD or at the following location:
<Install_Directory>\Cypress\CY3280-20X66\<version>\Firmware\
I2C-USBBridgeSoftwareConfig.
5. Go to File > Open File > CY3280_SLM_Project1.iic to select the file for iic commands.
6. Select +5V in the Power Settings box. See Figure 3-4.
7. Click Toggle Power to power the I2USB bridge; the red LED D1 glows, as shown in Figure 3-3.
Figure 3-4. Toggle Power Button
8. Send the commands in the Editor pane to the controller board.
Note Close PSoC Designer and PSoC Programmer before opening Bridge Control Panel.
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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Figure 3-5. Bridge Control Panel Editor View
9. Click on Send to send commands to the controller board; click Repeat to get parameters continuously from the controller.
10.Touch a button or slider. Each touch lights up the associated LED on the module board, representing where your finger is on the slider.
Figure 3-6. LED2 Glows on Touching Sensor SLD4
11. Click on the Chart tab to switch to Chart view and see the respective waveforms of CapSense
parameters.
18
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Figure 3-7. Bridge Control Panel Chart View
Note In the figure, the brown line represents the axis; the blue line indicates RawCount; and the
green line indicates the Baseline.
12.View the required parameters by selecting or clearing the checkboxes to the right of the Chart
view.
13.Click Stop to stop scanning.
14.Click the Table tab to view the values of the demonstration board variables, as shown in
Figure 3-8.
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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Figure 3-8. Bridge Control Panel Table View.
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4.
4.1
Hardware
System Block Diagram
The CY3280-20x66 Universal CapSense Controller board has the following sections:
■
PSoC CY8C20066A-24 LTXI
■
Power supply system
■
USB Mini B connector
■
CapSense module connector
■
ISSP/I2C connector
■
ICE-Cube debug connector
■
VADJ variable regulator control
■
LEDs
■
Reset switch
■
CMOD
0LQL3URJ
,&86%%ULGJH
,&(&XEH
86%&RPP
9%DWWHU\
9$GDSWHU
Figure 4-1. System Block Diagram
3RZHU
6HOHFWLRQ
-XPSHU
3RZHU
6XSSO\
&02'
,663,&
&RQQHFWRU
&DS6HQVH 0RGXOH
&RQQHFWRU
9$'- 9DULDEOH
5HJXODWRU
36R&
&<&$/;7,
/('V
86%0LQL%
&RQQHFWRU
,&(&XEH&RQQHFWRU
5HVHW
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4.2
Functional Description
The CY3280-20x66 Universal CapSense Controller includes PSoC CY8C20066A, ISSP connector,
CapSense module connector, USB Mini B connector, DC supply socket, Reset button, ICE-Cube
debug connector.
The following figure shows the different functional blocks on the CY3280-20x66 Universal CapSense
Controller board.
Figure 4-2. CY3280-20x66 Universal CapSense Controller Functional Blocks
ISSP/I2C
Connector
9 V Battery Terminal
Power LEDs
SPI/I2C
Header
DC Supply
Socket
Jumper for XRES
Selection
5 V and Vadj Voltage
Regulator ICs
Potentiometer
to control
Variable Voltage
GPIO Pins
Jumper to Select
Power Option
Reset Switch
ICE-Cube Debug
Connector
PSoC
CY8C20066A
Mini B
USB Connector
CapSense Module
Connector
4.2.1
PSoC CY8C20066A-24 LTXI
The PSoC CY8C20066A is initially factory programmed as a CapSense Controller with the control
circuitry to work with the CY3280-20x66 Universal CapSense Controller Kit. The PSoC
CY8C20066A along with CSA/CSD technology demonstrates the use of CapSense buttons and linear sliders; the module board connected to the CY3280-20x66 Universal CapSense Controller has
sensors and LEDs. The configuration number varies with the modules.
A CapSense module board is connected to the PSoC through Port P2. The list of pins connected to
different ports is shown in Pin Description of CY8C20066A-24LTXI on page 24.
PSoC CY8C20066A is programmed through ISSP using a MiniProg. Data acquisition and output
checking is done using I2USB bridge.
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Figure 4-3. Schematic View of PSoC CY8C20066A
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P1[7]b
VBUS
P4[0]
P4[1]
P4[2]
P4[3]
22
22
DP
DM
18
47
TAB
0402
0402
0402
0402
0805
0805
0402
CY8C20066
NOTE:
Place all resistors close to PSoC
49
0402
GND1
GND2
0603
0402
2
32.768KHz XTAL
C16
NO LOAD
DP
DM
0603
0402
Y1
1
1 R17
0402
0 OHM
0402
0402
R49
560
560
560
560
0402
0402
0805
P2_0
P2_1
P2_2
P2_3
P2_4
P2_5
P2_6
P2_7
0402
0402
2
33
5
34
4
35
3
36
2
P1[0]b
P1[1]b
0402
0 OHM
0402
560
560
560
560
560
560
560
560
0402
R45
P3[0]
560
2
7.5K
P3[2]
560
P3[3]
560
P3[4]
560
P3[5]
560
P3[6]
560
P3[7]
560
0402
R39
R41
R43
R46
R48
R50
R51
R53
0402
P2[0]
P2[1]
P2[2]
P2[3]
P2[4]
P2[5]
P2[6]
P2[7]
P3_0
P3_1
P3_2
P3_3
P3_4
P3_5
P3_6
P3_7
0402
C7
2200 pFd
0805
560
560
560
560
P0_0
P0_1
P0_2
P0_3
P0_4
P0_5
P0_6
P0_7
0402
R30
R32
R34
R36
0402
P0[4]
P0[5]
P0[6]
P0[7]
37
48
38
46
39
45
40
44
560
560
560
0402
R23
R25
R27
0402
P0[0]
P0[1]
P0[2]
CMOD
0402
TP1
CMOD
2NO LOAD
2NO LOAD
0805
R22
NO LOAD
1 R6
1 R13
0805
43
42
15
14
0402
56 ohm
56 ohm
56 ohm
56 ohm
0402
R5
R7
R8
R9
0402
OCDE
OCDO
HCLK
CCLK
0402
Maintain solid GND under
OCDx and xCLK signals.
0402
U1
DEFAULT JUMPER PIN 2 TO 3
21
41
NOTE:
1
1
1 PIN HDR
HEADER 3
0805
0402
1
0805
C2
10 uFd 16V
0805
J7
1
2
3
C15
NO LOAD
DO NOT POPULATE
MHz Crystal
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4.2.1.1
24
Pin Description of CY8C20066A-24LTXI
Pin No
Name
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
OCDOE
P2[7]
P2[5]
P2[3]
P2[1]
P4[3]
P4[1]
P3[7]
P3[5]
P3[3]
P3[1]
P1[7]
P1[5]
CCLK
HCLK
P1[3]
P1[1]
VSS
D+
DVDD
P1[0]
P1[2]
P1[4]
P1[6]
XRES
P3[0]
P3[2]
P3[4]
P3[6]
P4[0]
P4[2]
P2[0]
P2[2]
P2[4]
P2[6]
P0[0]
P0[2]
P0[4]
P0[6]
VDD
OCDO
OCDE
P0[7]
P0[5]
P0[3]
VSS
P0[1]
Description
OCD mode direction pin
GPIO, LED1
Crystal output (XOut), LED0
Crystal input (XIn), CapSense
CapSense
GPIO
GPIO
GPIO
GPIO
CapSense
GPIO
I2C SCL, SPI SS
I2C SDA, SPI MISO
OCD CPU clock output
OCD high speed clock output
SPI CLK, CapSense
ISSP CLK[3], I2C SCL, SPI MOSI
Ground connection
USB D+
USB DSupply voltage
ISSP DATA[3], I2C SDA, SPI CLK[4]
GPIO, LED4
Optional external clock input (EXTCLK), CapSense
CapSense
Active high external reset with internal pull down
CapSense
CapSense
GPIO
GPIO
GPIO
GPIO
CapSense
CapSense
CapSense
CapSense
GPIO
CapSense
CapSense
CapSense
Supply voltage
OCD even data I/O
OCD odd data output
GPIO
GPIO, LED3
Integrating input
Ground connection
GPIO, LED2
Connected To
P2
P2
P2
P2
P3
P3
P3
P3
P2
P2
P2, J2
P2, J4, J2
P1
P1
P2
P2, J3, J2
J6
J6
P2, J3, J2
P2
P2
P2
J4
P2
P2
P3
P3
P3
P3
P2
P2
P2
P2
P2
P2
P2
P2
P1
P1
P2
P2
P2
P2
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4.2.2
Power Supply System
The power supply system on this board is versatile; it takes input supply from the following sources:
■
12 V DC supply using connector J5
■
9 V battery connector using connectors BH1 and BH2
■
USB power (5 V) from communications section using connector J6
■
Power from MiniProg and I2USB bridge (Vcc_Prog) connected at J3
■
Power from ICE-Cube (Vcc_Prog) connected at P1
The board power domain is split into:
■
Vin rail: This is the rail where the input of on-board regulators are connected. This domain is
powered through protection diodes (by 12 V DC supply and 9 V battery terminal).
■
5V rail: This is the output of the 5 V regulator IC U3. The rail has a fixed 5 V output regardless of
jumper settings. The voltage in this rail can be lesser than 5 V only when the board is powered by
the USB.
■
Vadj rail: This is the output of the variable voltage regulator control.
■
VCC_PROG: This is power from devices such as MiniProg, I2USB bridge, ICE-Cube debugger.
The following block diagram shows the structure of the power system on the board.
Figure 4-4. Power Supply System Structure
9LQ
9
9'&6XSSO\
9 5HJXODWRU
9DGM
9 %DWWHU\
9DGM 5HJXODWRU
9FFB3URJ
,&(&XEH
,663
,&
9
86%
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Figure 4-5. Schematic View of Power Supply System Structure
Vin
BH1
BAT 9V FEMALE
D3
POS
1
2
SOD123
1
DIODE SCHOTTKY
9V
BH2
NEG
1
BAT 9V MALE
Adj Regulator (1.2V to 5.0V As Is Here)
5.0V Regulator
6V-12V
Vout = 1.242V x (1 + Res2/Res1)
5V
1
2
DIODE SCHOTTKY
3
POWER JACK P-5
U4
1
VIN
VOUT
GND
BYP
5
4
3216
EN
MIC5205-5p0
2
+ C10
2.2 uFd 10v
3
VOUT
GND
ADJ
5
4
EN
(Res1)
MIC5205-ADJ
RegAdj
R64
3K
1%
3216
2
1
2
0402
C11
470 pF
Vadj
VIN
1
1
1
SOD123
0603
2
1
1
3
2
U3
2
D4
1
J5
+ C12
2.2 uFd 10v
(Res2)
1
1
2
2
R67
NO LOAD
C14
470 pF
0402
2
2
0805
3
R65
10K
ICE CubeConnector
VCC_Prog
USB Mini AB
P1
5V
6
7
1
3
5
7
9
11
13
15
17
19
S1
S2
1
3
5
7
9
11
13
15
17
19
S3
S4
2
4
6
8
10
12
14
16
18
20
8
9
OCDE
2
4
6
8
10
12
14
16
18
20
20 Pin Hirose Recp
Place pin 1 toward
board edge.
J6
VBUS
DM
DP
ID
GND
D5
1
2
3
4
5
VBUS
DM
DP
2
SOD123
1
DIODE SCHOTTKY
USB MINI AB
R66
100K
4.2.2.1
0402
0402
C13
0.01 uFd
ISSP / I2C
J3
1
1 2
2 3
3 4
4 5
5
VCC_Prog
ISSP/I2C
J4
XRES
XRES/INT
P1[1]
P1[0]
P1[5]b
1
2
3
1
2
3
HEADER 3
HDR 1x5
NOTE:
DEFAULT JUMPER PIN 1 TO 2
Power Supply Jumper Setting
The jumper settings for each power setting are as follows
4.2.3
■
To allow power to be supplied by the MiniProg, I2USB bridge, and ICE-Cube, connect J7 to pin 2
of J1 with a jumper.
■
To allow power from the 12 V DC supply or 9 V battery terminal or USB Mini B connector, connect
pin 2 and 3 of J1 with a jumper.
■
To allow power from the variable regulator control (Vadj), connect pins 1 and 2 of J1 with a
jumper.
USB Mini B Connector
The USB Mini B connector is a mini port to communicate between the PC and the board. It is also
used to power up the controller, supplying 5 V voltage. Protection diode D5 is present so that the 5 V
from the board does not flow to the USB connector.
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Figure 4-6. Schematic View of USB Mini B Port
8
9
S3
S4
S1
S2
6
7
5V
J6
VBUS
DM
DP
ID
GND
D5
1
2
3
4
5
2
VBUS
DM
DP
SOD123
1
DIODE SCHOTTKY
USB MINI AB
R66
100K
4.2.4
0402
0402
C13
0.01 uFd
CapSense Module Connector
The CY3280-20x66 has an expansion port, P2. It is designed to connect CapSense module boards.
The CY3280-20x66 controller board can be used with any of the Universal CapSense module
boards, such as the CY3280-SLM. Universal CapSense module boards can be interfaced to the
CY3280-20x66 controller via the 44-pin connector P2. The pin mapping for the port P2 is shown in
the following figure.
Figure 4-7. Schematic View of Port P2
Vin
5V
R57
1
0402
P1[0]
SDA
P0[5]
P0[1]
P2[5]
P2[1]
P1[5]
P1[2]
P1[6]
P3[2]
P2[2]
P2[6]
P0[2]
P0[6]
P2
43
41
39
2 zero 37
35
33
31
29
27
25
23
21
19
17
15
13
11
9
7
5
3
1
43
41
39
37
35
33
31
29
27
25
23
21
19
17
15
13
11
9
7
5
3
1
Vadj
44
42
40
38
36
34
32
30
28
26
24
22
20
18
16
14
12
10
8
6
4
2
44
42
40
38
36
34
32
30
28
26
24
22
20
18
16
14
12
10
8
6
4
2
R58 1
2 zero
0402
VCC
P1[1]
SCL
P0[7]
P2[7]
P2[3]
P3[3]
P1[7]
P1[3]
P1[4]
P3[0]
P2[0]
P2[4]
P0[0]
P0[4]
22x2_RA_Recptacle
4.2.5
ISSP/I2C Connector
In-system serial programming (ISSP) is used to program the PSoC device using MiniProg1 and the
USB cable. Plug in the MiniProg device to the ISSP header J3.
The ISSP connector is also used to connect the I2USB bridge to communicate between the PC and
the controller board. See Power Supply Jumper Setting on page 26. The pin mapping for the ISSP
connector is shown in the following figure.
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Figure 4-8. Schematic View of ISSP/I2C Connector.
ISSP / I2C
J3
1
1 2
2 3
3 4
4 5
5
VCC_Prog
J4
XRES
XRES/INT
P1[1]
P1[0]
P1[5]b
1
2
3
1
2
3
HEADER 3
HDR 1x5
NOTE:
4.2.6
DEFAULT JUMPER PIN 1 TO 2
ICE-Cube Debug Connector
The CY3215-DK ICE-Cube in-circuit debugger allows you to debug and view the content of specific
memory locations. The ICE-Cube debugger can be connected to the CY3280-20x66 controller
through port P1. See Power Supply Jumper Setting on page 26. The following figure shows the
schematic view of the ICE-Cube debug connector.
Figure 4-9. Schematic View of ICE-Cube Connector.
2
0805
C1
0402
1
OCDE
No Load
R1
1K
VCC_Prog
OCDO
0805
C5
0402
1
3
5
7
9
11
13
15
17
19
No Load
R4
1K
CCLK
20 Pin Hirose Recp
Place pin 1 toward
board edge.
2
0805
C6
0402
1
3
5
7
9
11
13
15
17
19
2
2
4
6
8
10
12
14
16
18
20
1
2
4
6
8
10
12
14
16
18
20
1
P1
No Load
R21
1K
2
0805
C8
0402
1
HCLK
No Load
R38
1K
R55
1
2
XRES
4.2.7
0402
0402
C9
100 pFd
0402
R56
100 ohm
1K
VADJ Variable Regulator Control
The CY3280-20x66 controller has a variable regulator control used to vary input voltage using the
voltage regulator IC U4. The input for the variable regulator control is the output of the 5 V regulator.
Vadj is used to demonstrate CapSense at several voltages.
The minimum Vout from IC U4 is 1.242 V when the resistance at R67 is 0. This load at R67 can be
varied using the potentiometer. If the load at R67 is 3 K, the output voltage is 2.484 V; if the load at
R67 is 9 K, the output voltage is 4.968 V.
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See Power Supply Jumper Setting on page 26 for the settings to use input source Vadj.
Figure 4-10. Schematic View of Vadj Regulator.
Adj Regulator (1.2V to 5.0V As Is Here)
Vout = 1.242V x (1 + Res2/Res1)
U4
3
5
VOUT
GND
ADJ
4
EN
(Res1)
R64
3K
1%
3216
2
1
0603
MIC5205-ADJ
RegAdj
1
2
Vadj
VIN
1
Vin
1
+ C12
2.2 uFd 10v
(Res2)
R67
NO LOAD
1
1
2
2
C14
470 pF
0402
2
2
0805
3
R65
10K
4.2.8
LEDs
The LEDs are used to show the status of the controller board. LED D2 lights up on connecting power
supply from 12 V DC supply or USB or 9 V battery. LED D1 lights up when the board is powered by
any of the following power sources: 12 V DC supply, USB, 9 V battery, MiniProg, I2USB bridge, or
ICE-Cube.
Figure 4-11. Schematic View of LEDs D1 and D2.
5V
VCC
D1
LED Green
0805
1
1
D2
LED Green
0805
0805
4.2.9
R3
1K
2
2
0805
R2
1K
Reset Switch
The Reset switch resets PSoC to start of the program (code examples). On reset, after XRES deasserts, the SDA and SCL lines drive resistive low for eight sleep clock cycles and transition to high
impedance state.
Figure 4-12. Schematic View of RESET Switch
VCC
Reset
S1
1B
2B
1
R63
0402
1A
2A
2
100 ohm
XRES
SW PUSHBUTTON
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4.2.10
CMOD
CMOD is the test point provided on the Universal CapSense Controller for accessibility of charge
and discharge waveforms of the measured capacitance. This test point may increase the noise sensitivity by acting as an antenna.
Figure 4-13. Schematic View of CMOD
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Code Examples
All code examples are available in the Firmware folder of the kit CD or at the following location:
<Install_Directory>\Cypress\CY3280-20x66\<version>\Firmware\
5.1
My First Code Example (CY3280_20x66 CSD PD Project1)
5.1.1
Project Description
This project demonstrates the use of CapSense buttons and linear slider on the CY3280-SLM board
using CSD technology and CY8C20x66A. The EzI2Cs user module is used to transfer CapSense
parameters related to a sensor from the board to the PC for monitoring.
This project scans five CapSense buttons and a 10-segment slider using the CSD user module.
There are five LEDs on the board, which illuminate when a CapSense button or slider is touched.
The EzI2Cs user module is used to provide a register-based I2C slave communications protocol.
The status of CapSense sensors (both button and slider) and their parameters are updated in the
I2C register, which can be accessed by any I2C master, similar to the I2USB bridge.
The application starts by executing boot.asm. The boot.asm initializes the hardware and invokes the
'main' function. The main function initializes the EzI2Cs Slave and CapSense user modules. After
initialization, the main function enters into a loop, which does the following:
■
Scans all sensors
■
Reads the sensor ID sent by the I2C master
■
Stores CapSense data in the I2C registers
■
Updates the LED status for the On/Off sensors
The following user modules are used in this project:
CSD: The CSD provides capacitance sensing using the switched capacitor technique with a sigmadelta modulator to convert the sensed switching capacitor current to digital code.
EzI2Cs: The EzI2Cs user module implements an I2C register based slave device. This user module
does not require any digital or analog PSoC blocks. It is used to transfer all CapSense parameters
related to a sensor to the PC for monitoring
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5.1.2
Flowchart
Start
Enable Global
Interrupts. Clear
all LED’s
Set RAM buffer
Start I2C, CSD user modules.
Initialise Baseline and set
finger threshold
Scan all sensors and update
baseline of each sensor
Store RawCount, Baseline, Difference
count, Sensor Mask into I2C buffer for all
sensors
Is any Capsense
button active?
No
Store 0xFF as default active
button data in I2C buffer
No
Store 0x00 as default slider
status data in I2C buffer
Yes
Store active button number in
I2C buffer
Get finger position on slider
Is finger present
on slider?
Yes
Store finger position on slider
in I2C buffer
Turn ON Led based on active
sensor number
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5.1.3
Creating My First PSoC 1 Project
1. Open PSoC Designer.
2. To create a new project, click File> New Project.
3. In the New Project window, select the Chip-level icon. Name the project
Example_My_First_PSoC_Project, as shown in Figure 5-1.
4. Click Browse and navigate to the directory in which the project is created.
Figure 5-1. New Project
5. Click OK. The Select Project Type window opens.
6. In the Select Target Device option, click View Catalog, as shown in Figure 5-2.
Figure 5-2. Select Project Type
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7. The Device Catalog window opens. Click on the PSoC tab and scroll down to the CY8C202X6,
CY8C203X6, CY8C204X6, CY8C205X6, CY8C206X6 section.
8. Click CY8C20666A-24TQXI and then click Select; see Figure 5-3.
Figure 5-3. Device Catalog
9. Under Generate 'Main' File Using: select C and then click OK.
10. By default, the project opens in Chip view, as shown in Figure 5-4.
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Figure 5-4. Default View
11. The next step is to place and configure the modules required for this design, as well as connect
the modules together and to the pins of the PSoC. In the User Modules window, expand the Cap
Sensors folder.
Figure 5-5. Cap Sensors Folder
12.In this folder, right click on CSD and select Place.
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Figure 5-6. User Modules Window - CSD Select
Figure 5-7. CSD User Module Placement
13.Configure the CSD_1 properties, as shown in Figure 5-8:
36
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
[+] Feedback
Code Examples
Figure 5-8. CSD User Module Properties
14.Right-click on the CSD user module and select the CSD Wizard option to assign pins to the sensors.
Figure 5-9. Open CSD Wizard
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Figure 5-10. CSD Wizard
15.Configure the Global Settings in the CSD Wizard window.
Figure 5-11. Global Settings - CSD Wizard
16.Click on the slider in the CSD Wizard to view sensor settings. Configure the Sensor Settings, as
shown in Figure 5-12.
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Figure 5-12. Sensors Settings - CSD Wizard
17.To assign the sensor on a particular pin, click and drag from the sensor block to the required pin
in the Pin Assignment window. Drag and drop SW0 to pin P1 [6]. Sensor pin assignment can be
done in Table Pin Assignment View (Figure 5-14) or Chip Pin Assignment View (Figure 5-13).
Figure 5-13. Assign Sensors to Pins - Chip Pin Assignment View
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Figure 5-14. Assign Sensors to Pins - Table Pin Assignment View
18.After assigning a sensor, the CSD Wizard looks as shown in Figure 5-15.
Figure 5-15. Sensor Assigned
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19.Similarly, assign all the sensors according to the following table
Table 5-1. Sensor Assignment
Sensor
Port Pin
SW0
P1[6]
SW1
P1[3]
SW2
P3[3]
SW3
P2[1]
SW4
P2[3]
S1(0)
P1[4]
S1(1)
P0[6]
S1(2)
P0[4]
S1(3)
P0[2]
S1(4)
P2[6]
S1(5)
P2[4]
S1(6)
P2[2]
S1(7)
P2[0]
S1(8)
P3[2]
S1(9)
P3[0]
20.After assigning all the sensors successfully, the CSD Wizard appears as follows:
Figure 5-16. All Sensors Assigned - Table Pin Assignment View
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Figure 5-17. All Sensors Assigned - Chip Pin Assignment View
21.In the User Modules window, expand the Digital Comm folder, select EzI2Cs, right-click and
select Place to place an EzI2Cs in the design.
Figure 5-18. User Module Window - EzI2Cs Select
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22.By default, the EzI2Cs is placed at the I2C/SPI block. The placement of EzI2Cs module is shown
in Figure 5-19.
Figure 5-19. EzI2Cs User Module Placement
23.Configure the properties of EzI2Cs_1 as shown.
Figure 5-20. EzI2Cs User Module Properties
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24.Configure the properties of port pin P2[5] in the Pinout window as shown.
Figure 5-21. P2[5] Port Pin Properties
25.Configure the properties of P2[7], P0[1], P0[5] and P1[2] as shown in the following figures.
Figure 5-22. P2[7] Port Pin Properties
Figure 5-23. P0[1] Port Pin Properties
Figure 5-24. P0[5] Port Pin Properties
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Figure 5-25. P1[2] Port Pin Properties
26.Configure the Global Resources window as follows.
Figure 5-26. Global Resources
27.Open the existing main.c file in Workspace Explorer. Replace the existing main.c content with the
content of the embedded Example_My_First_PSoC_Project_Main.c file, which is attached to this
PDF.
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Figure 5-27. Workspace Explorer
28.Add a new file to the project by clicking File > New File.
Figure 5-28. Add New File
29.Select the C file type and name the file.
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Figure 5-29. File Types
30.Similarly, create two .h file types and name them as main.h and display.h, respectively.
Figure 5-30. New Files in Project
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31.Copy content of the Display.C, Display.h, and Main.h files that is attached to this PDF to the
respective files in the project.
32.Click Build > Generate/Build 'Example_My_First_PSoC_Project'.
33.Connect the CY3280-20X66 board to the PC using a MiniProg1.
Figure 5-31. Connect MiniProg1 to Board
34.The board can be programmed either through PSoC Designer IDE or by launching PSoC Programmer. To program the board using PSoC Programmer, see Programming PSoC with New
Design on page 16. To program the board through PSoC Designer, follow these steps.
Note While programming the board with PSoC Designer, close any open instance of PSoC Programmer.
a. Click on Program > Program Part.
Figure 5-32. Program Part Window
Toggle Power Button
Program Button
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b. In Program Part window, make sure the following settings:
Port Selection drop-down, select MiniProg1/xxxxxxxxxxx and Connected
Acquire Mode: Power Cycle
Verification: Off
Power Settings: 5.0 V
c. Click on the Program button to start programming the board.
Note Ensure that the shorting jumpers is placed on pin 2 of J1 and pin 1 of J7.
d. The board starts programming and the status is shown on the progress bar.
Figure 5-33. Programming Status
35.When the programming is done successfully, the 'Operation Succeeded!' Message is shown.
Figure 5-34. 'Operation Succeeded!' Message
5.1.4
Verify Output
Follow these steps to verify the output:
1. Connect a Linear Slider Module (SLM) on connector P2 of the board.
2. Disconnect the MiniProg1 from the header J3 and connect a CY3240-I2USB bridge board in its
place.
3. Connect a USB cable from the CY3240-I2USB bridge board to a free USB port on a PC.
4. Click Start > Programs > Cypress > Bridge Control Panel <version> > Bridge Control Panel
<version>. Note Make sure that PSoC Designer and PSoC Programmer are closed before
opening the Bridge Control Panel.
5. Select Variable Settings from the Chart menu.
6. Click Load, navigate to open the CY3280_SLM_Project1.ini file and click OK.
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7. Click Open File from the File menu; navigate to and open the CY3280_SLM_Project1.iic file.
8. Select +5V in the power settings box. Click Toggle Power to power the CY3240-I2USB bridge,
LED (red) D1glows.
Figure 5-35. SLM Module and CY3240-I2USB Bridge Connected to CapSense Controller
9. On the CapSense slider board, touch the button. Each button touch lights up the associated LED
on the module board.
10.Touch the linear slider. The associated LED on the module board lights up, representing where
your finger is on the slider.
11. The CapSense parameters such as the RawCount, Baseline, Difference Count and Mask Info
(refer CSD User module data sheet for more details of each parameter) for a particular sensor
can be seen on the Bridge Control Panel. The current active button number and finger position
on slider are also output on the Bridge Control Panel.
12.The syntax of the first command line, is as follows:
W
Write command
05
Slave Id
(constant)
0
Address Offset
(constant)
1
Sensor number
(In hexadecimal,
p
Stop
Valid range: 0x1 - 0xF)
13.The first command writes to the Universal CapSense Controller (UCC) board, the sensor number
for which the monitoring is required.
14.The second command line reads the CapSense parameters from the UCC board.
15.Change the sensor ID for which parameter monitoring is required and click Send to write the sensor ID to the Universal CapSense Controller board.
Figure 5-36. Command Line View
16.Click on the second command line and then click Repeat to read I2Cdata received from the Universal CapSense Controller board.
17.Switch to the Chart tab to view the respective wave forms of CapSense parameters.
50
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
[+] Feedback
Code Examples
Figure 5-37. Bridge Control Panel Chart View
18.The various parameter values received by the UCC is displayed in the Table tab.
Figure 5-38. Bridge Control Panel Table View
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5.2
CY3280_20x66 CSD PD Project2
5.2.1
Project Description
This project demonstrates the use of CapSense buttons and linear sliders using CSD technology
and CY8C20x66A. The EzI2Cs user module is used to transfer the raw count of CapSense parameters related to all the sensors to PC for monitoring.
This project scans five CapSense buttons and a 10-segment slider using the CSD user module.
There are five LEDs on the board, which illuminate when a CapSense button or slider is touched.
The EzI2Cs user module is used to provide a register-based I2C slave communications protocol.
The status of CapSense sensors (both button and slider) and their parameters are updated in the
I2C register, which can be accessed by any I2C master, similar to the I2USB bridge.
The application starts by executing boot.asm. The boot.asm initializes the hardware and invokes the
‘main’ function. The main function initializes the EzI2Cs slave and CapSense user modules. After initialization, the main function enters into a loop, which does the following:
■
Scans all sensors
■
Reads the sensor ID sent by the I2C master
■
Stores CapSense data in the I2C registers
■
Updates the LED status for the On/Off sensors
The following user modules are used in this project:
CSD: The CSD user module provides capacitance sensing using the switched capacitor technique
with a sigma-delta modulator to convert the sensed switching capacitor current to digital code.
EzI2Cs: The EzI2Cs user module implements an I2C register based slave device. This user module
does not require any digital or analog PSoC blocks. It is used to transfer all CapSense parameters
related to a sensor to the PC for monitoring.
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5.2.2
Device Configurations
Figure 5-39. Device Configuration for CY3280_20x66 CSD PD Project2.
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5.2.3
Firmware Architecture
Start
Enable Global
Interrupts. Clear
all LED’s
Set RAM buffer
Start I2C, CSD user modules.
Initialise Baseline and set
finger threshold
Scan all sensors and update
baseline of each sensor
Store RawCount of all sensors in I2C
buffer
Is any Capsense
button active?
No
Store 0xFF as default active
button data in I2C buffer
No
Store 0x00 as default slider
status in I2C buffer
Yes
Store active button number in
I2C buffer
Get finger position on slider
Is finger present
on slider?
Yes
Store finger position on slider
in I2C buffer
Turn ON Led based on active
sensor number
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5.2.4
Verify Output
Load CY3280_SLM_Project2.iic file from the Bridge Control Panel, as explained in Bridge Control
Panel
on
page 17.
This
file
is
available
in
the
following
location:
<Install_Directory>\Cypress\CY3280-20X66\<version>\Firmware\I2C-USBBridgeSoftwareConfig
1. Touch one or more buttons; the associated LEDs light up.
2. Touch the linear slider; the associated LEDs light up.
3. Touch the linear slider and buttons simultaneously. The associated LEDs light up corresponding
to the buttons and the sliders being pressed.
4. Click on the command line and then click Repeat to read I2C data received from the Universal
CapSense Controller board.
5. Switch to the Chart tab to view respective wave forms of CapSense parameters; see Figure 5-41.
Note The character ‘r’ in Figure 5-40 defines the start of "read data" command.
Figure 5-40. Command Line View
Figure 5-41. Bridge Control Panel Chart View
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Note The brown line in the figure represents the axis.
5.3
CY3280_ 20x66 CSA PD Project1
5.3.1
Project Description
This project demonstrates the use of CapSense buttons and linear sliders using CSA technology
and CY8C20x66A. The EzI2Cs user module is used to transfer CapSense parameters related to a
sensor to a PC for monitoring.
This project scans five CapSense buttons and a 10-segment slider using the CSA user module.
There are five LEDs on the board, which illuminate when a CapSense button or slider is touched.
The EzI2Cs user module is used to provide a register-based I2C slave communications protocol.
The status of CapSense sensors (both button and slider) and their parameters are updated in the
I2C register, which can be accessed by any I2C master, similar to the I2USB bridge.
The application starts by executing boot.asm. The boot.asm initializes the hardware and invokes the
‘main’ function. The main function initializes the EzI2Cs slave user module and CapSense user module. After initialization, the main function enters into a loop, which does the following:
■
Scans all sensors
■
Reads the sensor ID sent by the I2C master
■
Stores CapSense data in the I2C registers
■
Updates the LED status for the On/Off sensors
To make the CapSense sensors more sensitive, decrease the IDAC setting in the CSA user module
properties in PSoC Designer. However, this also increases the time it takes to scan each sensor. For
more information on these or other parameters and the user module in general, see the CSA user
module data sheet.
The following user modules are used in this project:
CSA: The CSA user module implements an array of capacitive touch sensors using switched capacitor circuitry, an analog multiplexer, digital counting functions, and high-level software routines to
compensate for environmental and physical sensor variations.
EzI2Cs: The EzI2Cs user module implements an I2C register based slave device.The EzI2Cs user
module does not require any digital or analog PSoC blocks. The EzI2Cs user module is used to
transfer all CapSense parameters related to a sensor to the PC for monitoring.
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5.3.2
Device Configurations
Figure 5-42. Device Configuration for CY3280_20x66 CSA PD Project1.
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5.3.3
Firmware Architecture
Start
Enable Global
Interrupts. Clear
all LED’s
Set RAM buffer
Start I2C, CSA user modules.
Initialise Baseline and set
finger threshold
Scan all sensors and update
baseline of each sensor
Store RawCount, Baseline, Difference
count, Sensor Mask into I2C buffer for all
sensors
Is any Capsense
button active?
No
Store 0xFF as default active
button data in I2C buffer
No
Store 0x00 as default slider
status data in I2C buffer
Yes
Store active button number in
I2C buffer
Get finger position on slider
Is finger present
on slider?
Yes
Store finger position on slider
in I2C buffer
Turn ON Led based on active
sensor number
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5.3.4
Verify Output
Load CY3280_SLM_Project1.iic file from the Bridge Control Panel, as explained in Bridge Control
Panel on page 17. This file is available in the following location: <Installed
Directory>\Cypress\CY3280-20X66\<version>\Firmware\I2C-USBBridgeSoftwareConfig
1. Touch one or more buttons; the associated LEDs light up.
2. Touch the linear slider; the associated LEDs light up.
3. Touch the linear slider and buttons simultaneously. The associated LEDs light up corresponding
to the buttons and the sliders being pressed.
4. The CapSense parameters such as the RawCount, Baseline, Difference Count and Mask Info
(refer CSD User module data sheet for more details of each parameter) for a particular sensor is
displayed on the Bridge Control Panel. The current active button number and finger position on
slider are also output on the Bridge Control Panel.
5. The syntax of the first command line, is as follows:
W
Write command
05
Slave Id
(constant)
0
Address Offset
(constant)
1
Sensor number
(In hexadecimal,
p
Stop
Valid range: 0x1 - 0xF)
6. The first command writes to the Universal CapSense Controller (UCC) board, the sensor number
for which the monitoring is required.
7. The second command line reads the CapSense parameters from the UCC board.
8. Change the sensor ID for which parameter monitoring is required and click Send to write the sensor ID to the Universal CapSense Controller board.
9. Switch to Chart tab to view the respective waveforms of CapSense parameters; see Figure 5-44.
Note The character ‘w’ in Figure 5-43 defines the start of "write data" command. Similarly, the character ‘p’ generates stop condition on the I2C bus and ‘r’ defines start of "read data"command.
Figure 5-43. Command Line View
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Figure 5-44. Bridge Control Panel Chart View
Note In the figure, the brown line represents the axis, the blue line indicates RawCount, and the
green line indicates the Baseline.
5.4
CY3280_ 20x66 CSA PD Project2
5.4.1
Project Description
This project demonstrates the use of CapSense buttons and linear sliders using CSA technology
and CY8C20x66A. The EzI2Cs user module is used to transfer the raw count of CapSense parameters related to all the sensors to PC for monitoring.
This project scans five CapSense buttons and a 10-segment slider using the CSA user module.
There are five LEDs on the board, which illuminate when either a CapSense button or slider is
touched. The EzI2Cs user module is used to provide a register-based I2C slave communications
protocol. The status of CapSense sensors (both button and slider) and their parameters are updated
in the I2C register, which can be accessed by any I2C master, similar to the I2USB bridge.
The application starts by executing boot.asm. The boot.asm initializes the hardware and invokes the
‘main’ function. The main function initializes the EzI2Cs slave and CapSense user modules. After
initialization, the main function enters into a loop, which does the following:
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■
Scans all sensors
■
Reads the sensor ID sent by the I2C master
■
Stores CapSense data in the I2C registers
■
Updates the LED status for the On/Off sensors
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To make the CapSense sensors more sensitive, you can decrease the IDAC setting in the CSA user
module properties within PSoC Designer. However, this also increases the time it takes to scan each
sensor. For more information on these or other parameters, and the user module in general, see the
CSA user module data sheet.
The following user modules are used in this project:
CSA: The CSA user module implements an array of capacitive touch sensors using switched capacitor circuitry, an analog multiplexer, digital counting functions, and high-level software routines to
compensate for environmental and physical sensor variations.
EzI2Cs: The EzI2Cs user module implements an I2C register based slave device.The EzI2Cs user
module does not require any digital or analog PSoC blocks. The EzI2Cs user module is used to
transfer all CapSense parameters related to a sensor to the PC for monitoring.
5.4.2
Device Configurations
Figure 5-45. Device Configuration for CY3280_20x66 CSA PD Project2
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5.4.3
Firmware Architecture
Start
Enable Global
Interrupts. Clear
all LED’s
Set RAM buffer
Start I2C, CSA user modules.
Initialise Baseline and set
finger threshold
Scan all sensors and update
baseline of each sensor
Store RawCount of all sensors in I2C
buffer
Is any Capsense
button active?
No
Store 0xFF as default active
button data in I2C buffer
No
Store 0x00 as default slider
status in I2C buffer
Yes
Store active button number in
I2C buffer
Get finger position on slider
Is finger present
on slider?
Yes
Store finger position on slider
in I2C buffer
Turn ON Led based on active
sensor number
62
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
[+] Feedback
Code Examples
5.4.4
Verify Output
Load CY3280_SLM_Project2.iic file from the Bridge Control Panel, as explained in Bridge Control
Panel on page 17. This file is available in the following location: <Installed
Directory>\Cypress\CY3280-20X66\<version>\Firmware\I2C-USBBridgeSoftwareConfig
1. Touch one or more buttons; the associated LEDs light up.
2. Touch the linear slider: the associated LEDs light up.
3. Touch the linear slider and buttons simultaneously. The associated LEDs light up corresponding
to the buttons and the sliders being pressed.
4. Click on the command line and then click Repeat to read I2C data received from the Universal
CapSense Controller board.
5. Switch to the Chart tab to view respective waveforms of CapSense parameters; see Figure 5-47.
Figure 5-46. Command Line View
Figure 5-47. Bridge Control Panel Chart View
Note The brown line in the figure represents the axis.
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Appendix
The schematic, board layouts, and BOM are available on the CY3280-20x66 kit CD or at:
<Install_directory>:\Cypress\CY3280-20x66\<version>\Hardware.
A.1
Schematic
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Board Layout
A.2.1
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No
Qty
Reference
Part
Manufacturer
Manuf. Part#
1
1
C2
CAP CER 10UF 16V X5R 0805
Murata Electronics North
America
2
2
C3,C4
CAP .1UF 16V CERAMIC Y5V 0402
Panasonic - ECG
ECJ-0EF1C104Z
GRM2165C1H222JA01D
ECJ-0EC1H101J
GRM21BR61C106KE15L
3
1
C7
CAP CER 2200PF 50V 5% C0G 0805
Murata Electronics North
America
4
1
C9
CAP 100PF 50V CERAMIC 0402 SMD
Panasonic - ECG
5
2
C10,C12
CAP 2.2UF 10V TANTALUM 10% 3216
AVX
TPSA225K010R1800
6
2
C11,C14
CAP 470PF 50V CERAMIC 0402 SMD
Panasonic - ECG
ECJ-0EB1H471K
7
1
C13
CAP 10000PF 16V CERAMIC 0402
SMD
Panasonic - ECG
ECJ-0EB1C103K
8
2
D1,D2
LED GREEN CLEAR 0805 SMD
LITE-ON
LTST-C170GKT
9
2
D4,D5
DIODE SCHOTTKY 0.5A 20V SOD-123
Fairchild Semiconductor
MBR0520L
AMP Division of TYCO
87220-3
10
2
J1,J4
CONN HEADER VERT 3POS .100
30AU
11
1
J3
CONN HEADER 5POS 0.1 VERT
KEYED
Molex
22-23-2051
12
1
J5
CONN 2.1MM PWRJACK RT ANGLE
PCB
Switchcraft
RAPC722X
13
1
J6
CONN USB MINI AB SMT RIGHT
ANGLE
TYCO
1734035-2
14
1
J7
CONN HEADER VERT 1POS .100
TYCO
9-146280-0-01
15
1
P1
RECP VERT 20POS HIROSE
Hirose
DF12-5.0-20DP-0.5V-81
16
1
P2
CONN FMALE 44POS DL .1" R/A GOLD Sullins Electronics Corp.
PPPC222LJBN-RC
17
1
P3
CONN RCPT .100 DUAL STR 10POS
3M
929852-01-05-RA
18
5
R1,R4,R21,R38,R56
RES 1.0K OHM 1/16W 5% 0402 SMD
Phycomp USA Inc
9C1A04021001JLHF3
19
2
R2,R3
RES 1K OHM 1/10W 5% 0805 SMD
Panasonic - ECG
ERJ-6GEYJ102V
20
4
R5,R7,R8,R9
RES 56 OHM 1/16W 5% 0402 SMD
Panasonic - ECG
ERJ-2GEJ560X
21
30
R10,R14,R15,R18,R23,
R24,R25,R27,R28,R29,
R30,R31,R32,R33,R34,
R35,R36,R37,R39,R40,
R41,R42,R43,R44,R46,
R47,R48,R50,R51,R53
RES 560 OHM 1/16W 5% 0402 SMD
Yageo Corporation
RC0402JR-07560RL
22
6
R11,R12,R16,R19,R55,
R63
RES 100 OHM 1/16W 5% 0402 SMD
Rohm
MCR01MZPJ101
23
1
R26
RES 7.5K OHM 1/8W 5% 0805 SMD
Panasonic - ECG
ERJ-6GEYJ752V
24
2
R52,R54
RES 22 OHM 1/16W 5% 0603 SMD
Panasonic - ECG
ERJ-3EKF22R0V
25
2
R57,R58
RES ZERO OHM 1/16W 0402 SMD
Panasonic - ECG
ERJ-2GE0R00X
26
1
R64
RES 3.00K OHM 1/16W 1% 0603 SMD
Yageo America
9C06031A3001FKHFT
27
1
R65
POT 10K CARBON LAYDOWN (103)
Panasonic - ECG
EVN-D8AA03B14
28
1
R66
RES 100K OHM 1/16W 5% 0402 SMD
Panasonic - ECG
ERJ-2GEJ104X
29
1
S1
LT SWITCH 6MM 100GF H=7MM TH
Panasonic - ECG
EVQ-PAC07K
Keystone Electronics
5001
30
3
TP1,TP4,TP7
TEST POINT 43 HOLE 65 PLATED
BLACK
31
4
TP2,TP3,TP5,TP6
TEST POINT 43 HOLE 65 PLATED RED Keystone Electronics
5000
32
1
U1
IC, 48QFN PSoC Device w/ OCD
Cypress Semiconductor
CY8C20066A-24LTXI
33
1
U3
IC REG LDO 150MA 5.0V 1% SOT23-5
Micrel
MIC5205-5.0YM5
34
1
U4
IC REG LDO 150MA ADJ 1% SOT23-5
Micrel
MIC5205YM5
68
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No
Qty
Reference
Part
Manufacturer
Manuf. Part#
Do Not Load
35
1
BH1
BATTERY HOLDER 9V Female PC MT
Keystone Electronics
594
36
1
BH2
BATTERY HOLDER 9V Male PC MT
Keystone Electronics
593
37
1
D3
DIODE SCHOTTKY 0.5A 20V SOD-123
Fairchild Semiconductor
MBR0520L
38
1
J2
CONN HEADER VERT 6POS .100 TIN
Molex/Waldom Electronics 22-28-4060
39
3
R59,R60,R61,R62
RES 560 OHM 1/16W 5% 0402 SMD
Panasonic - ECG
ERJ-2GEJ563X
40
6
R6,R13,R17,R20,R22,
R67
RES NO LOAD 0805 SMD
NA
NA
41
1
U2
IC DGTL POT SPI 10K 10-MSOP
Analog Devices Inc
AD5161BRMZ10
42
2
R45,R49
RES NO LOAD 0805 SMD
NA
NA
Citizen America Corporation
CFS308-32.768KDZF-UB
43
1
Y1
CRYSTAL 32.768 KHZ CYL 12.5PF
CFS308
44
4
C1,C5,C6,C8
CAP NO LOAD 0805
NA
NA
45
4
C15,C16
CAP NO LOAD 0603
NA
NA
Richco Plastic Co
RBS-35
Additional Assembly Instructions
46
Place jumper (0.100" pitch) across pins 2 and 3 of J1
47
Place jumper (0.100" pitch) across pins 1 and 2 of J4.
Install On Bottom of PCB As Close To Corners As Possible
48
4
n/a
BUMPER CLEAR.370X.19" CYLINDER
CY3280-20x66 Universal CapSense Controller Kit Guide, Doc. No. 001-67447 Rev. *A
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